Bug 1885936

Summary: [release 4.5] Collect ServiceAccount statistics
Product: OpenShift Container Platform Reporter: Martin Kunc <mkunc>
Component: Insights OperatorAssignee: Ricardo Lüders <rluders>
Status: CLOSED ERRATA QA Contact: Pavel Šimovec <psimovec>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.5CC: aos-bugs, inecas, psimovec, tremes
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Feature: Implements the Service Account Gatherer to the Insights Operator to collect field managementState of Openshift Operators. Reason: If the lib-bucket-provisioner service account missing then the creation of lib-bucket-provisioner InstallPlan is overloading the etcd and impacting the performance of the OCP cluster. Therefore we need access to this data. Result: Data is being collected, anonymized, and stored at the Insights Operator archive report.
Story Points: ---
Clone Of: 1885935
: 1885937 (view as bug list) Environment:
Last Closed: 2021-03-11 06:55:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1885941    
Bug Blocks: 1885937    

Description Martin Kunc 2020-10-07 10:17:58 UTC
+++ This bug was initially created as a clone of Bug #1885935 +++

+++ This bug was initially created as a clone of Bug #1885930 +++

This is adding collection of ServiceAccounts statistics from Openshift namespaces

Comment 3 Pavel Šimovec 2021-03-01 15:56:59 UTC
automated test on PR passed

Comment 6 errata-xmlrpc 2021-03-11 06:55:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.34 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0714