Bug 1887735

Summary: Can't add hosts due to ansible versions mismatches
Product: Red Hat Enterprise Virtualization Manager Reporter: Roni <reliezer>
Component: ovirt-engineAssignee: Dana <delfassy>
Status: CLOSED DUPLICATE QA Contact: meital avital <mavital>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 4.4.2CC: aefrat, jmacku, khakimi, lsurette, michal.skrivanek
Target Milestone: ---Keywords: Automation, AutomationBlocker, Regression
Target Release: ---Flags: aefrat: needinfo? (michal.skrivanek)
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-10-14 05:43:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Roni 2020-10-13 08:48:24 UTC
Created attachment 1721144 [details]
engine logs

Description of problem:
Fail to add a host to engine, host installation fail!

Version-Release number of selected component (if applicable):
4.3.11.4-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Install v4.3 HE environment
2. Add host to engine
3.

Actual results:
Add host fails

Expected results:
Add a host should succeded


Additional info:
Event log:
An error has occurred during installation of Host host_mixed_3: Yum [u'ovirt-hosted-engine-setup-2.3.13-2.el7ev.noarch requires ansible = 2.9.13'].

Comment 3 Michal Skrivanek 2020-10-14 05:43:30 UTC
already reported

*** This bug has been marked as a duplicate of bug 1887268 ***

Comment 4 Avihai 2020-10-14 10:21:16 UTC
(In reply to Michal Skrivanek from comment #3)
> already reported
> 
> *** This bug has been marked as a duplicate of bug 1887268 ***

This is hitting another place than the dup bug 1887268 instead of RHVH manager it occurs here at host addition and has no known WA as in dup bug ("yum update --nobest").
Is there a WA for this ? can we somehome add "yum update --nobest" to host deploy?

Comment 5 Michal Skrivanek 2020-10-14 13:56:47 UTC
yes, as the bug describes "RHEL hosts being used as hypervisors apparently have the same issue", it's for the host too.

as for workaround - the same one works (i.e. upgrade the host manually instead of GUI). And the bug will be fixed, of course.