Bug 1889462

Summary: System doesn't detect headphone jack status on thunderbolt dock
Product: [Fedora] Fedora Reporter: Mark Pearson <mpearson>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: brunovern.a, gombosg, jorton, lpoetter, rdieter, vondruch, wtaymans
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-09-20 13:54:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1816645, 1816768    

Description Mark Pearson 2020-10-19 17:55:42 UTC
Description of problem:

I don't know if this is *really* a problem or if it can/should be fixed - but wanted the opinion of more knowledgeable people :)

If the system (we've been testing with P1G3 and P15 for the upcoming Fedora release) is attached to our Thunderbolt 3 Workstation dock when you plug a headset into the dock the audio doesn't switch to that output automatically as it does if you plug the headphones into the jack on the platform itself.

I assume this is because of the fact that it's really a device on the other side of a thunderbolt connection, and we don't switch to those automatically by design.

Can we confirm this is working as designed, or if it would/should be a future enhancement. I can see it being a nice to have but don't know what would be involved to actually get it working.

Note - guessing at pulse as the component...figured it could be alsa or maybe even kernel? Please redirect appropriately.

Thanks
Mark

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. System connected to Dock playing thumping tunes
2. Plug in headset to dock. Note audio doesn't switch
3. Change audio settings to use thunderbolt dock audio. Party on.

Actual results: No audio from earphones


Expected results: audio from earphones


Additional info:

Comment 1 Vít Ondruch 2020-11-09 22:15:12 UTC
Also, I'd expect that if output is routed via dock, but headphones are connected to LP, the headphones gets priority. At least that is how it used to work with older docks.

Comment 2 Mark Pearson 2021-09-20 13:54:48 UTC
Closing bug as WONTFIX - realistically nobody is gonna look at this and I'm tired of looking at it every time I do a bug scrub.