Bug 1889949

Summary: [RFE] How much memory should capsule have versus our documentation
Product: Red Hat Satellite Reporter: Gary Scarborough <gscarbor>
Component: DocumentationAssignee: satellite-doc-list
Status: NEW --- QA Contact: satellite-doc-list
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.7.0CC: aruzicka, inecas, sokeeffe, zhunting
Target Milestone: UnspecifiedKeywords: FutureFeature
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gary Scarborough 2020-10-21 04:08:52 UTC
Description of problem:

What is the minimum amount of ram that capsule needs?  The 6.3 documentation only had one install guide and one set of system specs.  Those specs for both Satellite and Capsule indicated 20 GB of ram.  Before satellite 6.3, the amount required for Capsule was listed as 12 GB of ram.  The documentation for Satellite 6.4 broke the install guide into multiple parts.  The guides for 6.4 to 6.7 list 12 GB of ram as the minimum for capsule.

12 GB seems kind of low for our current system and I have always gone with the 20 GB guideline.

The reason I ask is case 02759375 where a customer's capsule was unable to publish the primary.xml.gz file for rhel 7.8 with only 16 GB of ram.  Once the system ram was increased, the capsule was able to successful create the file for the repo.  Details of the error can be found in KCS 5504721.

This has left the customer questioning the need for more ram.

So was the documentation for 6.3 wrong or is the newer documentation wrong?

Do we need to revise our required specs?

Comment 1 Lukas Zapletal 2020-10-21 09:33:05 UTC
I am going to flip this over to the platform/installer team where also memory check is being done. Generally speaking, Capsule can have minimum to big requirements depending on how many features are enabled.

Comment 2 Zach Huntington-Meath 2020-11-02 15:46:10 UTC
Developer note: this is on by default in el8