Bug 1890417

Summary: amavisd-new-snmp can't be installed on EL8 because of dropped net-snmp-perl
Product: [Fedora] Fedora EPEL Reporter: Peter Bieringer <pb>
Component: amavisAssignee: Juan Orti <jorti>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel8CC: janfrode, jorti, perl-devel, ppisar, steve, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: amavis-2.12.1-3.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-03 02:09:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Bieringer 2020-10-22 06:55:15 UTC
Description of problem:
amavisd-new-snmp can't be installed on EL8 because of dependency "net-snmp-perl"  was dropped from EL8 and also not available on EPEL8

Version:
2.12.0-9


How reproducible:
always


Steps to Reproduce:
yum install amavisd-new-snmp
Last metadata expiration check: 0:15:58 ago on Thu Oct 22 08:35:19 2020.

Actual results:

Error: 
 Problem: cannot install the best candidate for the job
  - nothing provides perl(NetSNMP::ASN) needed by amavis-snmp-2.12.0-9.el8.noarch
  - nothing provides perl(NetSNMP::OID) needed by amavis-snmp-2.12.0-9.el8.noarch
  - nothing provides perl(NetSNMP::agent) needed by amavis-snmp-2.12.0-9.el8.noarch
  - nothing provides perl(NetSNMP::default_store) needed by amavis-snmp-2.12.0-9.el8.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Expected results:
working

Additional info:
There is "net-snmp-perl" available on Okay-repo, but this downgrades also net-snmp-libs (and others).

Imho it was a very strange decission to drop the "net-snmp-perl", because potentially this cannot even put dedicated into EPEL8...

Comment 1 Petr Pisar 2020-10-22 08:31:03 UTC
You are right that net-snmp-perl is not provided by EL 8. And that's a mistake in amavisd-new-snmp package. But that could change in EL 8.3 version because CentOS Stream 8, that is a rolling preview of the next RHEL minor release, provides the package <http://mirror.centos.org/centos/8-stream/AppStream/x86_64/os/Packages/net-snmp-perl-5.8-17.el8.x86_64.rpm>. Thus I believe this bug gets resolved when EL 8.3 is released.

Comment 2 Fedora Update System 2020-11-17 12:25:13 UTC
FEDORA-EPEL-2020-ca1ac5519e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-ca1ac5519e

Comment 3 Fedora Update System 2020-11-18 03:15:17 UTC
FEDORA-EPEL-2020-ca1ac5519e has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-ca1ac5519e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-12-03 02:09:32 UTC
FEDORA-EPEL-2020-ca1ac5519e has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.