Bug 1890534

Summary: Counter metrics are decreasing which should not be allowed
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: RoutingAssignee: Stephen Greene <sgreene>
Status: CLOSED ERRATA QA Contact: Arvind iyengar <aiyengar>
Severity: high Docs Contact:
Priority: high    
Version: 3.11.0CC: agogala, aiyengar, alegrand, amcdermo, anpicker, aos-bugs, bshirren, dhansen, erooth, hongli, kakkoyun, lcosic, mcalizo, mjahangi, mloibl, mwasher, pkrupa, rheinzma, surbania
Target Milestone: ---Keywords: Reopened
Target Release: 4.5.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: HAProxy is reloaded when the router changes the configuration file Consequence: Some counter prometheus metrics were decreasing across reloads which explicitly violates the definition of a counter metric. Fix: Have the router reload metrics code note the time of the last metrics scrape, to avoid scraping beyond the preserved counter values during a reload Result: Counter metrics do not see a sudden increase followed by a decrease when the router is reloading.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-05 12:47:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1752814    
Bug Blocks: 1890536    

Comment 3 Arvind iyengar 2020-10-27 05:14:09 UTC
Verified in "4.5.0-0.nightly-2020-10-22-231534" release version. With this payload, it is noted that the metric counters continue to increase or resets to zero during reload conditions but no decrements.

Comment 5 errata-xmlrpc 2020-11-05 12:47:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.17 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4325