Bug 1891305

Summary: bcc needs rebuild for llvm11
Product: [Fedora] Fedora Reporter: Dominique Martinet <g.fhnrunznrqeqf>
Component: bccAssignee: Jiri Olsa <jolsa>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: acaringi, jmarchan, jolsa, kvs, rdossant, skozina, tseewald
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: bcc-0.16.0-2.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-03 00:58:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Dominique Martinet 2020-10-25 13:15:56 UTC
Description of problem:
libbcc cannot be used

Version-Release number of selected component (if applicable):
bcc-0.16.0-1.fc33.x86_64

How reproducible:
always

Steps to Reproduce:
1. try to run any snippet or bpftrace
2. fails


Actual results:
# bpftrace 
bpftrace: symbol lookup error: /lib64/libbcc-no-libbpf.so.0: undefined symbol: _ZN4llvm13IRBuilderBase18CreateGlobalStringENS_9StringRefERKNS_5TwineEj, version LLVM_11

Expected results:
runs

Additional info:
I see it got rebuilt in rawhide (fc34) but not fc33, please tag a rebuild for fc33 as well.
I've rebuilt locally and that fixes that issue.

Comment 1 Fedora Update System 2020-10-25 14:31:47 UTC
FEDORA-2020-b102ce4fd6 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b102ce4fd6

Comment 2 Fedora Update System 2020-10-26 01:18:21 UTC
FEDORA-2020-b102ce4fd6 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b102ce4fd6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b102ce4fd6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Tom Seewald 2020-10-26 06:54:54 UTC
The update doesn't seem to fix it for me, am I missing something?

# rpm -q bcc
bcc-0.16.0-2.fc33.x86_64

# rpm -q llvm
llvm-11.0.0-0.3.rc1.fc33.x86_64

Yet when I try to run any of the bcc tools I get something similar to:

# /usr/share/bcc/tools/fileslower 
Traceback (most recent call last):
  File "/usr/share/bcc/tools/fileslower", line 32, in <module>
    from bcc import BPF
  File "/usr/lib/python3.9/site-packages/bcc/__init__.py", line 27, in <module>
    from .libbcc import lib, bcc_symbol, bcc_symbol_option, bcc_stacktrace_build_id, _SYM_CB_TYPE
  File "/usr/lib/python3.9/site-packages/bcc/libbcc.py", line 17, in <module>
    lib = ct.CDLL("libbcc.so.0", use_errno=True)
  File "/usr/lib64/python3.9/ctypes/__init__.py", line 374, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: /lib64/libbcc.so.0: undefined symbol: _ZN4llvm13IRBuilderBase18CreateGlobalStringENS_9StringRefERKNS_5TwineEjPNS_6ModuleE, version LLVM_11

Comment 4 Dominique Martinet 2020-10-26 07:56:21 UTC
Hm, I have a different version of llvm

$ rpm -q llvm
llvm-11.0.0-1.fc33.x86_64

It looks like it is in stable now so can you try to upgrade that?


unfortunately the problem is that llvm11 symbols changed while providing the same .so (_ZN4llvm13IRBuilderBase18CreateGlobalStringENS_9StringRefERKNS_5TwineEj became _ZN4llvm13IRBuilderBase18CreateGlobalStringENS_9StringRefERKNS_5TwineEjPNS_6ModuleE) so I don't think this can be caugh at rpm level unless we require/provide each symbol like kernel modules do but it probably wouldn't scale for all userspace :/

Comment 5 Tom Seewald 2020-10-26 20:11:07 UTC
Yes, now that llvm-11.0.0-1.fc33.x86_64 has hit stable the bcc tools work properly.

Comment 6 Rafael Fonseca 2020-10-26 20:48:51 UTC
(In reply to Tom Seewald from comment #5)
> Yes, now that llvm-11.0.0-1.fc33.x86_64 has hit stable the bcc tools work
> properly.

Glad to know that and thanks for testing!

Comment 7 Rafael Fonseca 2020-10-28 08:51:25 UTC
*** Bug 1892205 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2020-11-03 00:58:37 UTC
FEDORA-2020-b102ce4fd6 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.