Bug 189144

Summary: rpc.statd sometimes binds to cups port 631
Product: [Fedora] Fedora Reporter: Steve Wardell <okapi>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 5   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-16 11:51:09 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Steve Wardell 2006-04-17 12:45:07 EDT
Description of problem:
Last night I was having problems printing and found the following in the error log:
E [17/Apr/2006:01:33:03 -0400] StartBrowsing: Unable to bind broadcast socket -
Address already in use.

It seems that rpc.statd had bound to udp port 631. As 631 is the port cups uses,
cups was unable to start up.

Version-Release number of selected component (if applicable):

How reproducible:
Not sure but the situation is pretty straight forward about what's happening.

Steps to Reproduce:
1. Startup system
2. If rpc.statd does show in a netstat -anp as having bound to port 631, reboot
until it takes port 631
3. Start up cups
Actual results:
Cups gives the error message:
E [17/Apr/2006:01:33:03 -0400] StartBrowsing: Unable to bind broadcast socket -
Address already in use.

Expected results:
Cups would start up correctly as rpc.statd would not bind to port 631.

Additional info:
As a workaround, on a reboot after the erorr, rpc.statd bound to port 637 and
all was fine. rpc.statd should not bind to port 631.
Comment 1 Calvin Smith 2006-05-16 10:40:17 EDT
This is a known issue described in more detail in bug #103401
Comment 2 Tim Waugh 2006-05-16 11:51:09 EDT

*** This bug has been marked as a duplicate of 103401 ***