Bug 1891658

Summary: FTBFS with libavif 0.8.2
Product: [Fedora] Fedora Reporter: Mamoru TASAKA <mtasaka>
Component: eflAssignee: Tom "spot" Callaway <spotrh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: asn, dchen, sereinity, spotrh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: efl-1.25.1-4.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-27 05:15:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mamoru TASAKA 2020-10-27 01:13:41 UTC
Description of problem:
efl-1.25.1-2.fc34 now FTBFS with libavif 0.8.2

/builddir/build/BUILD/efl-1.25.1/src/modules/evas/image_loaders/avif/evas_image_load_avif.c:68:10: error: too many arguments to function ‘avifDecoderParse’
   68 |    res = avifDecoderParse(decoder, &raw);
      |          ^~~~~~~~~~~~~~~~
In file included from /builddir/build/BUILD/efl-1.25.1/src/modules/evas/image_loaders/avif/evas_image_load_avif.c:7:
/usr/include/avif/avif.h:707:12: note: declared here
  707 | avifResult avifDecoderParse(avifDecoder * decoder);
      |            ^~~~~~~~~~~~~~~~
/builddir/build/BUILD/efl-1.25.1/src/modules/evas/image_loaders/avif/evas_image_load_avif.c: In function ‘evas_image_load_file_data_avif_internal’:
/builddir/build/BUILD/efl-1.25.1/src/modules/evas/image_loaders/avif/evas_image_load_avif.c:155:15: error: too many arguments to function ‘avifDecoderParse’
  155 |         res = avifDecoderParse(decoder, &raw);
      |               ^~~~~~~~~~~~~~~~
In file included from /builddir/build/BUILD/efl-1.25.1/src/modules/evas/image_loaders/avif/evas_image_load_avif.c:7:
/usr/include/avif/avif.h:707:12: note: declared here
  707 | avifResult avifDecoderParse(avifDecoder * decoder);
      |            ^~~~~~~~~~~~~~~~


Additional info:

Reported upstream:
https://phab.enlightenment.org/T8844
For now I am going to disable libavif support because this affects efl -> xmms2 -> LXDE live spin

Comment 1 Mamoru TASAKA 2020-10-27 01:51:08 UTC
With efl-1.25.1-3.fc34 once libavif support is disabled.

Comment 2 Andreas Schneider 2020-11-02 14:33:05 UTC
What do we plan to do with Fedora 33? Disable AVIF or start fixing it. It is likely that libavif API will change in future again till they release version 1.0.

Comment 3 Mamoru TASAKA 2020-11-02 14:59:11 UTC
For me, I am not a maintainer of efl, I want to keep an eye on this because efl affects LXDE live spin, so either (i.e. disabling AVIF support or fixing this) is okay to me.

Note that I've already written a trial patch on: https://phab.enlightenment.org/file/download/jld3unadesnjhxefwaer/PHID-FILE-bpukruq2iwezauxd4egy/efl-1.25.1-libavif-0.8.2-UNTESTED.patch which may be good but currently I have no means to check if the patch _actually_ works (I don't know how to _actually_ use libavif with efl)

Comment 4 Mamoru TASAKA 2020-12-27 05:15:11 UTC
Once closing this.