Bug 1892006

Summary: Not accepting v1.0 config format in F33+
Product: [Fedora] Fedora Reporter: Michael Cronenworth <mike>
Component: conkyAssignee: Miroslav Lichvar <mlichvar>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 33CC: mlichvar, moceap
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: conky-1.12.1-1.fc33 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-17 02:17:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Cronenworth 2020-10-27 20:52:02 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0
Build Identifier: 

$ conky
conky: Syntax error (/home/user/.conkyrc:2: unexpected symbol near '#') while reading config file. 
conky: Assuming it's in old syntax and attempting conversion.
conky: [string "..."]:159: attempt to call a nil value (global 'loadstring')

Reproducible: Always

Actual Results:  
Conky does not start

Expected Results:  
Conky starts

A dependency must have changed? My conky config has not changed in two years. The conky versions in F32 and F33 are the same.

Comment 1 Michael Cronenworth 2020-10-31 03:10:22 UTC
Renaming title to what the issue is. Converting my conkyrc to lua allows conky to start.

I see lua was updated from 5.3 (F32) to 5.4 (F33) so that may be the issue.

Comment 2 Miroslav Lichvar 2021-03-08 13:34:41 UTC
It seems to be working for me. Can you please post a sample config that triggers this bug?

Comment 3 Michael Cronenworth 2021-03-08 13:50:06 UTC
Any v1.0 config format triggers a failure to start. I'll paste in a single liner that fails. It doesn't matter if it is a single line or hundreds of lines. Comments or no comments.

$ cat .conkyrc
Host: Test

Comment 4 Miroslav Lichvar 2021-03-08 14:42:42 UTC
Ok, that fails on both F32 and F33. There is an upstream fix:

https://github.com/brndnmtthws/conky/pull/1002

Maybe we can rebase to 1.12.1.

Comment 5 Fedora Update System 2021-03-08 16:02:24 UTC
FEDORA-2021-a63faa439d has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a63faa439d

Comment 6 Miroslav Lichvar 2021-03-08 16:26:40 UTC
FWIW, that single-line reproducer still doesn't work with the new version. I think a minimal valid old-syntax config should contain some TEXT.

Comment 7 Fedora Update System 2021-03-08 21:15:45 UTC
FEDORA-2021-a63faa439d has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a63faa439d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a63faa439d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Michael Cronenworth 2021-03-09 13:14:05 UTC
Yes, a TEXT block works just fine with the new update. Thanks, although I've switched to a Lua file now.

Comment 9 Fedora Update System 2021-03-17 02:17:18 UTC
FEDORA-2021-a63faa439d has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.