Bug 1892695

Summary: User is unable to create KafkaSource with v1beta
Product: OpenShift Container Platform Reporter: Jaivardhan Kumar <jakumar>
Component: Dev ConsoleAssignee: Jaivardhan Kumar <jakumar>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: high Docs Contact: Harsh Mishra <hmishra>
Priority: medium    
Version: 4.6CC: aballant, aos-bugs, dsantra, gamore, nmukherj, spathak
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
The console used a prior version of the `KafkaSource` object that used the `resources` and `serviceAccountName` fields in their specification. The v1beta1 version of the `KafkaSource` object removed these fields, due to which the user was unable to create the `KafkaSource` object with the v1beta1 version. This issue has been fixed now and the user is able to create the `KafkaSource` object with the v1beta1 version.
Story Points: ---
Clone Of: 1892653 Environment:
Last Closed: 2020-11-16 14:37:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1892653    
Bug Blocks:    
Attachments:
Description Flags
User is able to create KafkaSource with v1beta none

Description Jaivardhan Kumar 2020-10-29 13:26:07 UTC
+++ This bug was initially created as a clone of Bug #1892653 +++

Description of problem: User is unable to create KafkaSource with `v1beta` as resources / ServiceAccountName is spec is deprecated

https://github.com/knative/eventing-contrib/blob/master/kafka/source/pkg/apis/sources/v1alpha1/kafka_types.go#L89-L90
https://github.com/knative/eventing-contrib/blob/master/kafka/source/pkg/apis/sources/v1beta1/kafka_types.go

Prerequisites (if any, like setup, operators/versions):
Install Serverless operator, create CR for KnativeServing, KnativeEventing
Install knativa Kafka Operator, Install KEK CR in ns `knative-Eventing`

Steps to Reproduce
1. Created a ns
2. go to add - EventSources
3. Select KafkaSource
4. fill form data and click create


Actual results: Fails to create a kafkaSource with below error

Expected results: Should create a KafkaSource

--- Additional comment from Debsmita Santra on 2020-10-29 12:10:33 UTC ---

verified on build 4.7.0-0.nightly-2020-10-27-051128

Comment 2 spathak@redhat.com 2020-11-08 21:01:33 UTC
Created attachment 1727599 [details]
User is able to create KafkaSource with v1beta

Comment 3 spathak@redhat.com 2020-11-08 21:02:30 UTC
Verified on build version: 4.6.0-0.nightly-2020-11-07-035509
Browser version: chrome 84

Comment 6 errata-xmlrpc 2020-11-16 14:37:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.4 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4987