Bug 1894794

Summary: x2goserver should Require: xkbcomp setxkbmap instead of xorg-x11-xkb-utils
Product: [Fedora] Fedora Reporter: Peter Hutterer <peter.hutterer>
Component: x2goserverAssignee: Orion Poplawski <orion>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: orion
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-06 02:07:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1867220    

Description Peter Hutterer 2020-11-05 04:59:52 UTC
xorg-x11-xkb-utils is an aggregate package, shipping a few tools that should be in their own respective packages, see [1]. Of these x2goserver requires xkbcomp and setxkbmap.

We've had Provides: xkbcomp and Provides: setxkbmap in xorg-x11-xkb-utils for years:
$ dnf repoquery --whatprovides  xkbcomp
Last metadata expiration check: 0:07:46 ago on Thu 05 Nov 2020 13:32:47.
xorg-x11-xkb-utils-0:7.7-33.fc33.x86_64

x2goserver should switch to "Requires: xkbcomp setxkbmap" so we can actually obsolete the aggregate package and start using separate packages.

[1] https://fedoraproject.org/wiki/Changes/XorgUtilityDeaggregation



I'll push this change in the next few days if you don't beat me to it :)

Comment 1 Orion Poplawski 2020-11-06 02:07:15 UTC
Thanks, I've made the change since I'm poking at x2go/nxlibs at the moment.  Looks like we only need setxkbmap, unless you can point out where we need xkbcomp as well.

Comment 2 Peter Hutterer 2020-11-08 21:35:42 UTC
tbh I just assumed it needed xkbcomp since it looked like an X server :) I grepped for setxkbmap which is how I found that, but I didn't check for xkbcomp. But yeah, if you don't need to compile the keymap, then you don't need it. Thanks for the quick change, much appreciated.