Bug 1894892

Summary: [OSP13-only] Switch UseTLSTransportForNbd to false as a default
Product: Red Hat OpenStack Reporter: Martin Schuppert <mschuppe>
Component: openstack-tripleo-heat-templatesAssignee: Martin Schuppert <mschuppe>
Status: CLOSED ERRATA QA Contact: Pavan <pkesavar>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: amodi, camorris, mburns
Target Milestone: z14Keywords: Triaged, ZStream
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.4.1-72.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-16 13:55:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1906350    

Description Martin Schuppert 2020-11-05 11:20:47 UTC
Description of problem:

https://bugzilla.redhat.com/show_bug.cgi?id=1888951 has shown there is an issue with UseTLSTransportForNbd enabled per default for tls-everywhere environments. There is work ongoing to fix the certificate create + cert mounts into the container for tls-everywhere environments to support an upgrade path to UseTLSTransportForNbd: true for pre-existing instances.

For now switch off UseTLSTransportForNbd per default to get back the same configuration from before UseTLSTransportForNbd feature.

Version-Release number of selected component (if applicable):
OSP13

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 14 errata-xmlrpc 2020-12-16 13:55:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 13.0 director bug fix advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:5575