This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 189861

Summary: dhclient causes WPA authentication to be dropped
Product: [Fedora] Fedora Reporter: David Anderson <david>
Component: dhcpAssignee: Jason Vas Dias <jvdias>
Status: CLOSED WORKSFORME QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 5   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-04-25 08:08:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David Anderson 2006-04-25 07:06:45 EDT
Description of problem:

Running dhclient on my Atheros network card causes the previously successful 
WPA authentication to fail.

Version-Release number of selected component (if applicable):
3.0.3-26
(kmod-madwifi-0.0.0.20060317-3.2.6.16_1.2096_FC5, wpa_supplicant-0.4.8-7.fc5)

How reproducible:
Every time. (Tried about 5 times. As soon as I stopped using dhclient and 
instead configured manually, everything worked).
Access point is a LinkSys WAP54G.

Steps to Reproduce:
1. Insert Atheros-based wireless card
2. service wpa_supplicant start (configured with key_mgmt=WPA-PSK, proto=WPA)
3. Do "/sbin/iwconfig ath0 essid MYSSID"
4. Wait for "/sbin/iwconfig ath0" to demonstrate that association has been 
successful.
5. Run "dhclient ath0".

Actual results:
dhclient obtains an IP address, updates the interface, and then immediately 
wpa_supplicant gets authentication failed and remains in that state. (This 
causes dhclient to quit, too).

However, if you don't use dhclient (i.e. configure the interface manually with 
"ifconfig" and "route" and edit /etc/resolv.conf manually), then the interface 
continues working fine. (I am currently entering this bug via the interface in 
question, having configured it manually).

I used this same setup with this same access point on Fedora Core 4 (fully 
updated) about 2 months ago, and there were no problems.

Expected results:
Everything works happily.

Additional info:
My system is fully updated.
Comment 1 David Anderson 2006-04-25 08:08:55 EDT
Sorry - bug is elsewhere. Closing.