Bug 1899339

Summary: bug on kernel greater than 5.9 on Fedora 33. Black screen after resume from long suspend.
Product: [Fedora] Fedora Reporter: Rootware <xrootware>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 33CC: acaringi, adscvr, airlied, bskeggs, desw, hdegoede, itamar, jarodwilson, jeremy, jglisse, jonathan, josef, kernel-maint, lgoncalv, linville, mail, masami256, mchehab, mjg59, ptalbert, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-11 20:42:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
dmesg none

Description Rootware 2020-11-18 22:27:10 UTC
Created attachment 1730728 [details]
dmesg

Bug on kernel greater than 5.9 on Fedora 33. Black screen after resume from long suspend. Open/Close lid.

HARD RESET (power button 5 seconds) required to normal boot.

System encountered a non-fatal error in drm_dev_register()

WARNING: CPU: 2 PID: 323 at drivers/gpu/drm/drm_mode_config.c:617 drm_mode_config_validate+0x178/0x200 [drm] 


backtrace          [-M-O] 33 L:[ 14+15  29/ 43] *(3144/3968b) 0010 0x00A                                                            [*][X]
FС:  00007f051daef4c0(0000) GS:ffff8a3fb8a00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00007f22b257b56c CR3: 000000012ed8a000 CR4: 00000000003506f0
Call Trace:
 ? generic_reg_get+0x1d/0x30 [amdgpu]
 drm_get_last_vbltimestamp+0x8a/0xa0 [drm]
 drm_reset_vblank_timestamp+0x4b/0xb0 [drm]
 drm_crtc_vblank_on+0x7b/0x130 [drm]
 amdgpu_dm_atomic_commit_tail+0xd00/0x24c0 [amdgpu]
 commit_tail+0x94/0x130 [drm_kms_helper]
 drm_atomic_helper_commit+0x113/0x140 [drm_kms_helper]
 drm_atomic_helper_set_config+0x70/0xb0 [drm_kms_helper]
 drm_mode_setcrtc+0x1d3/0x6f0 [drm]
 ? avc_has_extended_perms+0x18d/0x3e0
 ? drm_mode_getcrtc+0x180/0x180 [drm]
 drm_ioctl_kernel+0x86/0xd0 [drm]
 drm_ioctl+0x20f/0x3a0 [drm]
 ? drm_mode_getcrtc+0x180/0x180 [drm]
 amdgpu_drm_ioctl+0x49/0x80 [amdgpu]
 __x64_sys_ioctl+0x83/0xb0
 do_syscall_64+0x33/0x40
 entry_SYSCALL_64_after_hwframe+0x44/0xa9
RIP: 0033:0x7f0521a5938b
Code: 89 d8 49 8d 3c 1c 48 f7 d8 49 39 c4 72 b5 e8 1c ff ff ff 85 c0 78 ba 4c 89 e0 5b 5d 41 5c c3 f3 0f 1e fa b8 10 00 00 00 0f 05 <48> 3
RSP: 002b:00007ffc9abfb628 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
RAX: ffffffffffffffda RBX: 00007ffc9abfb660 RCX: 00007f0521a5938b
RDX: 00007ffc9abfb660 RSI: 00000000c06864a2 RDI: 0000000000000009
RBP: 00000000c06864a2 R08: 0000000000000000 R09: 0000556b0af88830
R10: 0000000000000000 R11: 0000000000000246 R12: 0000556b083821e0
R13: 0000000000000009 R14: 00007f0504006650 R15: 0000556b0afa2980

BOOT_IMAGE=(hd0,gpt5)/boot/vmlinuz-5.10.0-0.rc4.78.fc34.x86_64 root=UUID=1ede796f-5c84-4fb0-8a9e-c97e1b102ec4 ro resume=UUID=1dad1a43-257

Comment 1 Rootware 2021-02-11 20:42:33 UTC

*** This bug has been marked as a duplicate of bug 1884180 ***