Bug 1902231 (CVE-2020-29129, CVE-2020-29130)

Summary: CVE-2020-29129 CVE-2020-29130 QEMU: slirp: out-of-bounds access while processing ARP/NCSI packets
Product: [Other] Security Response Reporter: Prasad J Pandit <ppandit>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: ailan, berrange, cfergeau, drjones, imammedo, itamar, jen, jferlan, jforbes, jmaloy, jnovy, knoel, marcandre.lureau, m.a.young, mkenneth, mrezanin, mst, ondrejj, pbonzini, philmd, ribarry, rjones, robinlee.sysu, virt-maint, virt-maint, vkuznets, wquan, xen-maint
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
An out-of-bounds access issue was found in the SLiRP user networking implementation of QEMU. It could occur while processing ARP/NCSI packets, if the packet length was shorter than required to accommodate respective protocol headers and payload. A privileged guest user may use this flaw to potentially leak host information bytes.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-05-18 14:36:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1902232, 1902234, 1902235, 1902236, 1902237, 1902238, 1902239    
Bug Blocks: 1887769    

Description Prasad J Pandit 2020-11-27 12:55:10 UTC
An out-of-bounds access issue was found in the SLiRP user networking implementation of QEMU. It could occur while processing ARP/NCSI packets, if the packet length was shorter than required to accommodate respective protocol headers and payload. A privileged guest user may use this flaw to potentially leak host information bytes.

Upstream patch:
---------------
  -> https://lists.freedesktop.org/archives/slirp/2020-November/000115.html

Comment 1 Prasad J Pandit 2020-11-27 12:55:18 UTC
Acknowledgments:

Name: Qiuhao Li

Comment 2 Prasad J Pandit 2020-11-27 12:55:46 UTC
Created qemu tracking bugs for this issue:

Affects: fedora-all [bug 1902232]

Comment 4 Prasad J Pandit 2020-11-27 13:23:37 UTC
External References:

https://www.openwall.com/lists/oss-security/2020/11/27/1

Comment 7 Product Security DevOps Team 2021-05-18 14:36:59 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2020-29129
https://access.redhat.com/security/cve/cve-2020-29130

Comment 8 errata-xmlrpc 2021-05-18 14:51:29 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 8

Via RHSA-2021:1762 https://access.redhat.com/errata/RHSA-2021:1762