Bug 1904825

Summary: Set vSphere hostname from guestinfo before NM starts
Product: OpenShift Container Platform Reporter: Vadim Rutkovsky <vrutkovs>
Component: Machine Config OperatorAssignee: Vadim Rutkovsky <vrutkovs>
Status: CLOSED ERRATA QA Contact: Michael Nguyen <mnguyen>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: amurdaca, jdelft, jerzhang, jhou, mnguyen
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: All   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: hostname from vSphere metadata was not set before NetworkManager started Consequence: due to a change in NetworkManager priorities this metadata was ignored when hostname was set Fix: hostname is now being set by `vsphere-hostname.service` before NM starts, if this information is available in vSphere metadata Result: vSphere node hostname is correct
Story Points: ---
Clone Of: 1904824 Environment:
Last Closed: 2021-04-20 19:27:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1904824    
Bug Blocks:    

Description Vadim Rutkovsky 2020-12-06 18:04:35 UTC
+++ This bug was initially created as a clone of Bug #1904824 +++

Description of problem:
In Fedora 33, a change was introduced to set the hostname to "fedora" as a fallback instead of the default "localhost", so the current script does not work in OKD as NM will assign the fallback hostname.

This change makes it so the hostname is set to vSphere's
guestinfo.hostname if that's defined, before NetworkManager is started.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vadim Rutkovsky on 2020-12-06 18:03:40 UTC ---

Fixed by https://github.com/openshift/machine-config-operator/pull/2282

Comment 36 errata-xmlrpc 2021-04-20 19:27:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.25 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1153