Bug 1907

Summary: Incomplete services (again)
Product: Red Hat Enterprise Linux 3 Reporter: rebel
Component: setupAssignee: Bill Nottingham <notting>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: andy, nalin, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-20 19:30:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 168872    

Description rebel 1999-03-31 11:27:59 UTC
The files /etc/services and /etc/protocols are rather
incomplete. Why not use the originally published by IANA?

Comment 1 Preston Brown 1999-03-31 22:44:59 UTC
setup-1.9.2-2 and later contain complete /etc/services and
/etc/protocols files.

Comment 2 Patrick C. F. Ernzer 2002-07-08 23:17:05 UTC
We have since this was fixed in 1999 become out of sync with the official list
again.

Could we please have another update or even better have it generated
automatically from <http://www.iana.org/assignments/port-numbers> when the rpm
is built?

Having an up to date services file makes parsing firewall log files so much easier.

Comment 3 Jay Turner 2003-09-09 13:54:54 UTC
We again have discrepancies with setup-2.5.27-1.1.

Comment 4 Bill Nottingham 2004-05-05 03:29:41 UTC
Cleaned up in 2.5.32-1.

Comment 5 Bill Nottingham 2004-05-05 03:41:50 UTC
Deferred from 2.5.32-1

Comment 6 Bill Nottingham 2004-09-23 05:33:01 UTC
*** Bug 82104 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Pitman 2005-04-12 09:08:53 UTC
Lot's of updates from November 2004, please ensure a new services file is in  
place for FC4.  Service that I'm looking for in particular is OpenVPN on 1194.  

Comment 8 Bill Nottingham 2005-09-20 19:30:38 UTC
This problem is scheduled to be resolved in a future major release of Red Hat
Enterprise Linux. Red Hat does not currently plan to provide a resolution for
this in a Red Hat Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects.