Bug 190707

Summary: xm create error creating domain
Product: [Fedora] Fedora Reporter: Demetri Mouratis <dmourati>
Component: xenAssignee: Jeremy Katz <katzj>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: adabalap, bstein, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-04 14:45:38 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Demetri Mouratis 2006-05-04 12:28:40 EDT
Description of problem:

Xm complains with Error Creating Domain when invoked on fresh install of FC5
domU running on Xen/FC5 domO.

# uname -a
Linux db4.rnmd.net 2.6.16-1.2107_FC5xen0 #1 SMP Tue May 2 19:36:56 EDT 2006 i686
i686 i386 GNU/Linux

# xenguest-install.py -n xendomain1 -f /home/xen/xendomain1 -s 25 -r 384 -l
http://ops1.rnmd.net/fedora/core/5/i386/os -x
ks=http://ops1.rnmd.net/kickstart/cfgs/ks-fedora-core-5-xen-guest.cfg

If your install has exited, you can restart your guest by running
'xm create -c xendomain1'.  Otherwise, you can reconnect to the console
by running 'xm console xendomain1'

[root@db4 ~]# xm create -c xendomain1
Using config file "/etc/xen/xendomain1".
Going to boot Fedora Core (2.6.15-1.2054_FC5smp)
  kernel: /vmlinuz-2.6.15-1.2054_FC5smp
  initrd: /initrd-2.6.15-1.2054_FC5smp.img
Error: Error creating domain: (22, 'Invalid argument')


Version-Release number of selected component (if applicable):


How reproducible:

(Almost) every time.  I got the process to work on one or two domains before it
starting crashing each time.

Steps to Reproduce:
1.  Install FC5
2.  Install Xen kernel
3.  Reboot into Xen kernel
4.  Run xenguest-install.py
5.  xm create -c newdomain
  
Actual results:

Going to boot Fedora Core (2.6.15-1.2054_FC5smp)
  kernel: /vmlinuz-2.6.15-1.2054_FC5smp
  initrd: /initrd-2.6.15-1.2054_FC5smp.img
Error: Error creating domain: (22, 'Invalid argument')

Expected results:

New domain boots successfully.

Additional info:

Seems to have something to do with PAE which is enabled both in the BIOS and in
the FC5 Xen dom0 kernel.

xend.log:
[2006-05-04 11:26:37 xend.XendDomainInfo] DEBUG (XendDomainInfo:1290)
XendDomainInfo.destroy: domid=9
[2006-05-04 11:26:37 xend.XendDomainInfo] DEBUG (XendDomainInfo:1298)
XendDomainInfo.destroyDomain(9)
[2006-05-04 11:26:37 xend] ERROR (SrvBase:87) Request create failed.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/web/SrvBase.py", line 85, in perform
    return op_method(op, req)
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
82, in op_create
    raise XendError("Error creating domain: " + str(ex))
XendError: Error creating domain: (22, 'Invalid argument')

xend-debug.log:
       [2006-05-04 11:26:37 xend] ERROR (SrvBase:87) Request create failed.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/web/SrvBase.py", line 85, in perform
    return op_method(op, req)
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
82, in op_create
    raise XendError("Error creating domain: " + str(ex))
XendError: Error creating domain: (22, 'Invalid argument')
[root@db4 log]# tail xend-debug.log
    vm.initDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1209,
in initDomain
    channel_details = self.image.createImage()
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 118, in
createImage
    return self.createDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 137, in
createDomain
    result = self.buildDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/image.py", line 188, in
buildDomain
    features       = self.features)
error: (22, 'Invalid argument')
Comment 1 Jeremy Katz 2006-05-23 15:04:24 EDT
Can you provide the contents of /sys/hypervisor/properties/capabilities and xm
dmesg?
Comment 2 Demetri Mouratis 2006-05-23 18:28:20 EDT
Hi Jeremy,

I don't see a /sys/hypervisor directory at all.  Is this useful:

[root@localhost ~]# cat /proc/xen/capabilities
control_d

Here's xm dmesg output:

[root@localhost ~]# xm dmesg
 __  __            _____  ___   ___
 \ \/ /___ _ __   |___ / / _ \ / _ \
  \  // _ \ '_ \    |_ \| | | | | | |
  /  \  __/ | | |  ___) | |_| | |_| |
 /_/\_\___|_| |_| |____(_)___(_)___/

 http://www.cl.cam.ac.uk/netos/xen
 University of Cambridge Computer Laboratory

 Xen version 3.0.0 (bhcompile@build.redhat.com) (gcc version 4.1.0 20060304 (Red
Hat 4.1.0-3)) Wed Apr 19 05:11:40 EDT 2006
 Latest ChangeSet: unavailable

(XEN) Console output is synchronous.
(XEN) Physical RAM map:
(XEN)  0000000000000000 - 00000000000a0000 (usable)
(XEN)  0000000000100000 - 000000007ffc0000 (usable)
(XEN)  000000007ffc0000 - 000000007ffcfc00 (ACPI data)
(XEN)  000000007ffcfc00 - 000000007ffff000 (reserved)
(XEN)  00000000f0000000 - 00000000f4000000 (reserved)
(XEN)  00000000fec00000 - 00000000fed00400 (reserved)
(XEN)  00000000fed13000 - 00000000feda0000 (reserved)
(XEN)  00000000fee00000 - 00000000fee10000 (reserved)
(XEN)  00000000ffb00000 - 0000000100000000 (reserved)
(XEN) System RAM: 2047MB (2096512kB)
(XEN) Xen heap: 10MB (10288kB)
(XEN) Using scheduler: Simple EDF Scheduler (sedf)
(XEN) PAE disabled.
(XEN) found SMP MP-table at 000fe710
(XEN) DMI 2.3 present.
(XEN) Using APIC driver default
(XEN) ACPI: RSDP (v000 DELL                                  ) @ 0x000fd160
(XEN) ACPI: RSDT (v001 DELL   PE850    0x00000001 MSFT 0x0100000a) @ 0x000fd174
(XEN) ACPI: FADT (v001 DELL   PE850    0x00000001 MSFT 0x0100000a) @ 0x000fd1b8
(XEN) ACPI: MADT (v001 DELL   PE850    0x00000001 MSFT 0x0100000a) @ 0x000fd22c
(XEN) ACPI: SPCR (v001 DELL   PE850    0x00000001 MSFT 0x0100000a) @ 0x000fd2a0
(XEN) ACPI: HPET (v001 DELL   PE830    0x00000001 MSFT 0x0100000a) @ 0x000fd2f0
(XEN) ACPI: MCFG (v001 DELL   PE830    0x00000001 MSFT 0x0100000a) @ 0x000fd328
(XEN) ACPI: DSDT (v001 DELL   PE830    0x00000001 MSFT 0x0100000e) @ 0x00000000
(XEN) ACPI: Local APIC address 0xfee00000
(XEN) ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
(XEN) Processor #0 15:4 APIC version 20
(XEN) ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
(XEN) Processor #1 15:4 APIC version 20
(XEN) ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
(XEN) ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
(XEN) ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
(XEN) IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-23
(XEN) ACPI: IOAPIC (id[0x03] address[0xfec10000] gsi_base[32])
(XEN) IOAPIC[1]: apic_id 3, version 32, address 0xfec10000, GSI 32-55
(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
(XEN) ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
(XEN) ACPI: IRQ0 used by override.
(XEN) ACPI: IRQ2 used by override.
(XEN) ACPI: IRQ9 used by override.
(XEN) Enabling APIC mode:  Flat.  Using 2 I/O APICs
(XEN) ACPI: HPET id: 0xffffffff base: 0xfed00000
(XEN) Using ACPI (MADT) for SMP configuration information
(XEN) Initializing CPU#0
(XEN) Detected 3000.287 MHz processor.
(XEN) CPU: Trace cache: 12K uops, L1 D cache: 16K
(XEN) CPU: L2 cache: 1024K
(XEN) CPU: Physical Processor ID: 0
(XEN) CPU: Processor Core ID: 0
(XEN) Intel machine check architecture supported.
(XEN) Intel machine check reporting enabled on CPU#0.
(XEN) CPU0: Intel P4/Xeon Extended MCE MSRs (24) available
(XEN) CPU0: Thermal monitoring enabled
(XEN) CPU0: Intel(R) Pentium(R) D CPU 3.00GHz stepping 07
(XEN) Booting processor 1/1 eip 90000
(XEN) Initializing CPU#1
(XEN) CPU: Trace cache: 12K uops, L1 D cache: 16K
(XEN) CPU: L2 cache: 1024K
(XEN) CPU: Physical Processor ID: 0
(XEN) CPU: Processor Core ID: 1
(XEN) Intel machine check architecture supported.
(XEN) Intel machine check reporting enabled on CPU#1.
(XEN) CPU1: Intel P4/Xeon Extended MCE MSRs (24) available
(XEN) CPU1: Thermal monitoring enabled
(XEN) CPU1: Intel(R) Pentium(R) D CPU 3.00GHz stepping 07
(XEN) Total of 2 processors activated.
(XEN) ENABLING IO-APIC IRQs
(XEN) ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
(XEN) checking TSC synchronization across 2 CPUs: passed.
(XEN) Platform timer is 14.318MHz HPET
(XEN) Brought up 2 CPUs
(XEN) Machine check exception polling timer started.
(XEN) *** LOADING DOMAIN 0 ***
(XEN) Domain 0 kernel supports features = { 0000001f }.
(XEN) Domain 0 kernel requires features = { 00000000 }.
(XEN) PHYSICAL MEMORY ARRANGEMENT:
(XEN)  Dom0 alloc.:   7e000000->7f000000 (480644 pages to be allocated)
(XEN) VIRTUAL MEMORY ARRANGEMENT:
(XEN)  Loaded kernel: c0100000->c0455b7c
(XEN)  Init. ramdisk: c0456000->c0842000
(XEN)  Phys-Mach map: c0842000->c0a1b610
(XEN)  Start info:    c0a1c000->c0a1d000
(XEN)  Page tables:   c0a1d000->c0a21000
(XEN)  Boot stack:    c0a21000->c0a22000
(XEN)  TOTAL:         c0000000->c0c00000
(XEN)  ENTRY ADDRESS: c0100000
(XEN) Dom0 has maximum 2 VCPUs
(XEN) Initrd len 0x3ec000, start at 0xc0456000
(XEN) Scrubbing Free RAM: .....................done.
(XEN) Xen trace buffers: disabled
(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch input to Xen).
(XEN) DOM1: (file=mm.c, line=460) Non-privileged attempt to map I/O space 00000000
(XEN) DOM1: (file=mm.c, line=460) Non-privileged attempt to map I/O space 00000000
Comment 3 Jeremy Katz 2006-05-24 10:38:38 EDT
Can you try with the newer xen0 kernel (which should be in -updates now I believe)
Comment 4 Demetri Mouratis 2006-05-24 12:00:24 EDT
Hi Jeremy,

I've done the patching and now have a related but new problem:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192911

Thanks.
Comment 5 Jeremy Katz 2006-06-04 14:45:38 EDT

*** This bug has been marked as a duplicate of 192911 ***