Bug 1907476

Summary: python-mpd2 fails to build with Python 3.10: TypeError: As of 3.10, the *loop* parameter was removed from Queue() since it is no longer necessary
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: python-mpd2Assignee: Ankur Sinha (FranciscoD) <sanjay.ankur>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mhroncok, sanjay.ankur, thrnciar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-mpd2-3.0.4-1.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-28 14:53:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1890881    

Description Tomáš Hrnčiar 2020-12-14 15:25:18 UTC
python-mpd2 fails to build with Python 3.10.0a3.

======================================================================
ERROR: test_mocker (mpd.tests.TestAsyncioMPD)
Does the mock server refuse unexpected writes?
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1095, in test_mocker
    self.init_client()
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1036, in init_client
    self._await(self.client.connect(TEST_MPD_HOST, TEST_MPD_PORT, loop=self.loop))
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1041, in _await
    return self.loop.run_until_complete(future)
  File "/usr/lib64/python3.10/asyncio/base_events.py", line 641, in run_until_complete
    return future.result()
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/asyncio.py", line 117, in connect
    self.__commandqueue = asyncio.Queue(loop=loop)
  File "/usr/lib64/python3.10/asyncio/queues.py", line 33, in __init__
    super().__init__(loop=loop)
  File "/usr/lib64/python3.10/asyncio/mixins.py", line 17, in __init__
    raise TypeError(
TypeError: As of 3.10, the *loop* parameter was removed from Queue() since it is no longer necessary

======================================================================
ERROR: test_oddhello (mpd.tests.TestAsyncioMPD)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1044, in test_oddhello
    self.assertRaises(mpd.base.ProtocolError, self.init_client, odd_hello=[b'NOT OK\n'])
  File "/usr/lib64/python3.10/unittest/case.py", line 732, in assertRaises
    return context.handle('assertRaises', args, kwargs)
  File "/usr/lib64/python3.10/unittest/case.py", line 201, in handle
    callable_obj(*args, **kwargs)
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1036, in init_client
    self._await(self.client.connect(TEST_MPD_HOST, TEST_MPD_PORT, loop=self.loop))
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1041, in _await
    return self.loop.run_until_complete(future)
  File "/usr/lib64/python3.10/asyncio/base_events.py", line 641, in run_until_complete
    return future.result()
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/asyncio.py", line 117, in connect
    self.__commandqueue = asyncio.Queue(loop=loop)
  File "/usr/lib64/python3.10/asyncio/queues.py", line 33, in __init__
    super().__init__(loop=loop)
  File "/usr/lib64/python3.10/asyncio/mixins.py", line 17, in __init__
    raise TypeError(
TypeError: As of 3.10, the *loop* parameter was removed from Queue() since it is no longer necessary

======================================================================
ERROR: test_status (mpd.tests.TestAsyncioMPD)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1051, in test_status
    self.init_client()
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1036, in init_client
    self._await(self.client.connect(TEST_MPD_HOST, TEST_MPD_PORT, loop=self.loop))
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/tests.py", line 1041, in _await
    return self.loop.run_until_complete(future)
  File "/usr/lib64/python3.10/asyncio/base_events.py", line 641, in run_until_complete
    return future.result()
  File "/builddir/build/BUILD/python-mpd2-1.1.0/mpd/asyncio.py", line 117, in connect
    self.__commandqueue = asyncio.Queue(loop=loop)
  File "/usr/lib64/python3.10/asyncio/queues.py", line 33, in __init__
    super().__init__(loop=loop)
  File "/usr/lib64/python3.10/asyncio/mixins.py", line 17, in __init__
    raise TypeError(
TypeError: As of 3.10, the *loop* parameter was removed from Queue() since it is no longer necessary

----------------------------------------------------------------------
Ran 62 tests in 0.518s

FAILED (errors=3, skipped=2)
ERROR: InvocationError for command /usr/bin/coverage3 run -m unittest mpd.tests (exited with code 1)
___________________________________ summary ____________________________________
ERROR:   py310: commands failed

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/01827220-python-mpd2/

For all our attempts to build python-mpd2 with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-mpd2/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Ben Cotton 2021-02-09 15:34:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 2 Ankur Sinha (FranciscoD) 2021-03-28 14:53:52 UTC
Seems to be fixed in the latest 3.0.4 release. Tested with the COPR. Closing now.