Bug 190909

Summary: lbxproxy
Product: [Fedora] Fedora Reporter: John <john_smyth>
Component: xorg-x11-server-utilsAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
URL: https://bugs.freedesktop.org/show_bug.cgi?id=3565
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-06 05:31:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description John 2006-05-06 05:53:08 EDT
Description of problem:
lbxproxy go to infinite loop or segfault

Version-Release number of selected component (if applicable):
xorg-x11-server-utils-1.0.1-1.2.x86_64.rpm

How reproducible:
from xterm | konsole | gnome-terminal | whatever
$ lbxproxy
OR
$ lbxproxy -pn

if IPv6 supported/enabled -> segfault

/var/log/messages
... lbxproxy[16935]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffb7ce10 error 6
... lbxproxy[16936]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffe98b80 error 6
... lbxproxy[17035]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffd62a70 error 6
... lbxproxy[17239]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffdb8480 error 6
... lbxproxy[17241]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffa839f0 error 6
... lbxproxy[17242]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffe9ede0 error 6
... lbxproxy[17243]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffd99300 error 6
... lbxproxy[17244]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffb0b880 error 6
... lbxproxy[17245]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffefbb10 error 6
... lbxproxy[17247]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffb7ae90 error 6
... lbxproxy[17248]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffc42c60 error 6
... lbxproxy[17249]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffc89430 error 6
... lbxproxy[17284]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007ffffff62390 error 6
... lbxproxy[17285]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffff95fd20 error 6
... lbxproxy[17286]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffbbb620 error 6
... lbxproxy[17288]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffffe99d90 error 6
... lbxproxy[17290]: segfault at 00000e2800000e20 rip 0000000000403620 rsp
00007fffff92f2c0 error 6

if IPv6 _NOT_ supported/enabled -> infinite loop
_LBXPROXYTransSocketOpenCOTSServer: Unable to open socket for local
_LBXPROXYTransOpen: transport open failed for local/hostname.internal:63
_LBXPROXYTransMakeAllCOTSServerListeners: failed to open listener for local
_LBXPROXYTransSocketOpenCOTSServer: Unable to open socket for inet6
_LBXPROXYTransOpen: transport open failed for inet6/hostname.internal:63
_LBXPROXYTransMakeAllCOTSServerListeners: failed to open listener for inet6
_LBXPROXYTransSocketOpenCOTSServer: Unable to open socket for inet
_LBXPROXYTransOpen: transport open failed for inet/hostname.internal:63
_LBXPROXYTransMakeAllCOTSServerListeners: failed to open listener for inet
_LBXPROXYTransSocketOpenCOTSServer: Unable to open socket for local
_LBXPROXYTransOpen: transport open failed for local/hostname.internal:64
_LBXPROXYTransMakeAllCOTSServerListeners: failed to open listener for local
_LBXPROXYTransSocketOpenCOTSServer: Unable to open socket for inet6
_LBXPROXYTransOpen: transport open failed for inet6/hostname.internal:64
_LBXPROXYTransMakeAllCOTSServerListeners: failed to open listener for inet6
_LBXPROXYTransSocketOpenCOTSServer: Unable to open socket for inet
_LBXPROXYTransOpen: transport open failed for inet/hostname.internal:64
_LBXPROXYTransMakeAllCOTSServerListeners: failed to open listener for inet
....


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2006-05-23 10:16:14 EDT
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 2 Mike A. Harris 2006-06-06 05:31:45 EDT
The upstream bug has been closed "WONTFIX", as LBX has been deprecated for
some time now.  The X.Org X11R7.1 release no longer supports LBX, and does
not come with lbxproxy.

We have plans to release X.Org X11R7.1 for Fedora Core 5 in the near future
once it has stabilized to a point we're comfortable with, and at that time
LBX will no longer be part of the distribution.

Since LBX and related utilities, etc. are no longer supported or maintained
upstream, and we will be removing them in an update in the future, I'm closing
this as WONTFIX.