Bug 1909108

Summary: Machine API components should use 1.20 dependencies
Product: OpenShift Container Platform Reporter: Joel Speed <jspeed>
Component: Cloud ComputeAssignee: Joel Speed <jspeed>
Cloud Compute sub component: Other Providers QA Contact: sunzhaohua <zhsun>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: mimccune
Version: 4.7   
Target Milestone: ---   
Target Release: 4.7.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
: 1913960 (view as bug list) Environment:
Last Closed: 2021-02-24 15:47:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Joel Speed 2020-12-18 11:33:47 UTC
Description of problem: We should be using the same client library version as the core of the openshift cluster and in particular the openshift and kube API servers


The following components will need to be bumped:
- Machine API Operator
- Cluster API Provider AWS
- Cluster API Provider Azure
- Cluster API Provide GCP
- Cluster Autoscaler
- Cluster Autoscaler Operator
- Cluster Machine Approver
- Cluster API Actuator PKG

Once Machine API Operator is bumped, we should bump all other CAPI providers to use the latest version of MAO as well.

Comment 4 Michael McCune 2021-01-07 21:07:27 UTC
hey, sorry i moved too slowly on the cluster autoscaler changes and missed adding my PR before this went ON_QA. i created another bz to get it, https://bugzilla.redhat.com/show_bug.cgi?id=1913960

Comment 5 Joel Speed 2021-01-08 10:55:52 UTC
Removing the block link as they are actually independent

Comment 6 sunzhaohua 2021-01-12 07:13:45 UTC
we didnt find regression issues in recent test, move this to done.
clusterversion: 4.7.0-fc.2

Comment 9 errata-xmlrpc 2021-02-24 15:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.0 security, bug fix, and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:5633