Bug 1910049

Summary: UPI: ansible-galaxy is not supported
Product: OpenShift Container Platform Reporter: Pierre Prinetti <pprinett>
Component: InstallerAssignee: Pierre Prinetti <pprinett>
Installer sub component: OpenShift on OpenStack QA Contact: weiwei jiang <wjiang>
Status: CLOSED ERRATA Docs Contact:
Severity: low    
Priority: unspecified Keywords: UpcomingSprint
Version: 4.7   
Target Milestone: ---   
Target Release: 4.7.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-24 15:48:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pierre Prinetti 2020-12-22 13:22:38 UTC
OpenStack playbooks recently started using ansible-galaxy[1].

Ansible-galaxy is an upstream project; supported workflows should be based on downstream code.

Moreover, ansible-galaxy didn't solve the Nova microversion-mismatch problem for which it was introduced.

[1]: https://github.com/openshift/installer/pull/4379

Comment 2 weiwei jiang 2020-12-28 07:07:34 UTC
Verified with 4.7.0-0.nightly-2020-12-21-131655.

Comment 5 errata-xmlrpc 2021-02-24 15:48:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.0 security, bug fix, and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2020:5633