Bug 1913813

Summary: Validation is not robust enough and may prevent to generate install-confing.
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: InstallerAssignee: Martin André <m.andre>
Installer sub component: OpenShift on OpenStack QA Contact: weiwei jiang <wjiang>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: pprinett
Version: 4.6Keywords: UpcomingSprint
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: A missing guard in the OpenStack validations could potentially lead to fetch the list of subnets with an empty subnet ID, and cause some non-RHOSP clouds to return unexpected values. Consequence: The unexpected error code would fail validation and prevent to install OpenShift on these non-RHOSP clouds. Fix: Add a missing guard against empty subnet ID Result: Validation now returns the expected result and as a consequence it is now possible to install OpenShift on more clouds.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-01 15:24:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1906517    
Bug Blocks:    

Comment 4 weiwei jiang 2021-01-26 02:42:14 UTC
Checked with 4.6.0-0.nightly-2021-01-25-161512, and can not reproduce this, so move to verified.


$ ./openshift-install-4.6 create install-config --dir bz1913813 --log-level debug
DEBUG OpenShift Installer 4.6.0-0.nightly-2021-01-25-161512 
DEBUG Built from commit 26aab99447a65a1a3d46342318486bd1dd11b1e2 
DEBUG Fetching Install Config...                   
DEBUG Loading Install Config...                    
DEBUG   Loading SSH Key...                         
DEBUG   Loading Base Domain...                     
DEBUG     Loading Platform...                      
DEBUG   Loading Cluster Name...                    
DEBUG     Loading Base Domain...                   
DEBUG     Loading Platform...                      
DEBUG   Loading Pull Secret...                     
DEBUG   Loading Platform...                        
DEBUG   Fetching SSH Key...                        
DEBUG   Generating SSH Key...                      
? SSH Public Key /home/wjiang/.ssh/openshift-qe.pub
DEBUG   Fetching Base Domain...                    
DEBUG     Fetching Platform...                     
DEBUG     Generating Platform...                   
? Platform openstack
? Cloud upshift
? ExternalNetwork provider_net_cci_8
? APIFloatingIPAddress 10.0.100.67
? FlavorName m1.xlarge
DEBUG   Generating Base Domain...                  
? Base Domain 10.0.100.67.nip.io
DEBUG   Fetching Cluster Name...                   
DEBUG     Fetching Base Domain...                  
DEBUG     Reusing previously-fetched Base Domain   
DEBUG     Fetching Platform...                     
DEBUG     Reusing previously-fetched Platform      
DEBUG   Generating Cluster Name...                 
? Cluster Name wjtest
DEBUG   Fetching Pull Secret...                    
DEBUG   Generating Pull Secret...                  
? Pull Secret [? for help] ************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************************
DEBUG   Fetching Platform...                       
DEBUG   Reusing previously-fetched Platform        
DEBUG Generating Install Config...                 
INFO Install-Config created in: bz1913813

Comment 6 errata-xmlrpc 2021-02-01 15:24:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.15 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0235