Bug 191417

Summary: Exception starting xend: (111, 'Connection refused')
Product: [Fedora] Fedora Reporter: Need Real Name <bugzilla>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: bstein, haswell, katzj, lannet, ondrejj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-18 12:49:02 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
trace file of starting xend with the option "trace_start"
Extract from /var/log/xend.log none

Description Need Real Name 2006-05-11 14:59:39 EDT
Description of problem:
xm fails to communicate with the xend service.

Version-Release number of selected component (if applicable):
xen-3.0.2-0.FC5.1 from updates-testing

How reproducible: Always

Steps to Reproduce:
1. /sbin/service xend start
2. xm list
Actual results:
Error: Error connecting to xend: No such file or directory.  Is xend running?

Expected results:
A list showing Dom0

Additional info:

Runing FC5 with the latest updates as of 05/11/2006.  (yum update).
uname -r output:

selinux is disabled in /etc/selinux/config:

I've tried both xen rpms from updates, as well as updates-testing.

both versions create these .pid files in /var/run:
-rwS--x--T 1 root root 5 May 11 11:13 xenconsoled.pid
-rw-r--r-- 1 root root 4 May 11 11:13 xend.pid
-rw------- 1 root root 5 May 11 11:13 xenstore.pid

some of the attributes for xenconsoled.pid seem odd btw...
out of all of those pid files, only the xend.pid has a matching, running process
with the same id.
ps ax|grep "xen"
 1513 ?        S      0:00 python /usr/sbin/xend start
 1516 ?        Sl     0:00 python /usr/sbin/xend start

netstat -a -n -p|grep python with updates-testing version of xen
(xen-3.0.2-0.FC5.1) shows:
tcp        0      0      *                  
LISTEN      1516/python

netstat -a -n -p|grep python with updates version of xen ( xen-3.0.1-4) shows an
additional listening socket:
tcp        0      0      *                  
LISTEN      1593/python
unix  2      [ ACC ]     STREAM     LISTENING     5306   1593/python        

Other things to note:
socket and socket_ro are created in /var/run/xendstored when the xend service is
started, and /var/lib/xenstored/tdb is created as well.

Stopping the xend service, doesn't wipe out any .pid file, nor those the socket,
socket_ro or that tdb file, but the running processes do die.

running /usr/sbin/xend trace_start shows these exceptions:

|     102     try:
|     103         inst
|    ! Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/XendNode.py", line 103, in
NameError: global name 'inst' is not defined
|     104     except:
|     105         inst = XendNode()
|    |> XendNode.py:__init__
|    |  31         self.xc = xen.lowlevel.xc.xc()

|     546     try:
|     547         inst
|    ! Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomain.py", line 547, in
NameError: global name 'inst' is not defined
|     548     except:
|     549         inst = XendDomain()
|    |> XendDomain.py:__init__
|    |  60         self.domains = {}
|    |  61         self.domains_lock = threading.RLock()

|    |      17         if not xs_handle:
|    |      18             xs_handle = xen.lowlevel.xs.xs()
|    |    ! Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/xenstore/xsutil.py", line 18,
in xshandle
    xs_handle = xen.lowlevel.xs.xs()
RuntimeError: (111, 'Connection refused')
|    |    < xenstore/xsutil.py:xshandle

with more of those 111, 'Connection refused' following...  I've included the
complete xend.trace file.
Comment 1 Need Real Name 2006-05-11 14:59:39 EDT
Created attachment 128908 [details]
trace file of starting xend with the option "trace_start"
Comment 2 Jan ONDREJ 2006-05-12 09:53:29 EDT
I have same problems with latest kernel-xen0-2.6.16-1.2111_FC5, works well after
reboot to older kernel kernel-xen0-2.6.16-1.2096_FC5.
May be it is a kernel problem.
Comment 3 lannet 2006-05-12 22:35:13 EDT
Created attachment 128970 [details]
Extract from /var/log/xend.log
Comment 4 Brian Stein 2006-05-18 12:49:02 EDT

*** This bug has been marked as a duplicate of 190899 ***