Bug 1914955

Summary: [Regression] Cannot install system using DVD on USB when ignoredisk is specified in kickstart
Product: Red Hat Enterprise Linux 8 Reporter: Renaud Métrich <rmetrich>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED MIGRATED QA Contact: Release Test Team <release-test-team-automation>
Severity: high Docs Contact: Sagar Dubewar <sdubewar>
Priority: high    
Version: 8.3CC: abustosp, brian.p.millett, byodlows, iasunsea, jcall, jhocutt, jkonecny, jstodola, sjalgaon, vponcova
Target Milestone: rcKeywords: MigratedToJIRA, Triaged
Target Release: 8.0   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
.The USB CD-ROM drive is not available as an installation source in Anaconda Installation fails when the USB CD-ROM drive is the source for it and the Kickstart `ignoredisk --only-use=` command is specified. In this case, Anaconda cannot find and use this source disk. To work around this problem, use the `harddrive --partition=sdX --dir=/` command to install from USB CD-ROM drive. As a result, the installation does not fail.
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-09-18 15:02:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Logs of rh82 installation (success) and rh83 installation (failure) + kickstart none

Description Renaud Métrich 2021-01-11 15:05:44 UTC
Created attachment 1746296 [details]
Logs of rh82 installation (success) and rh83 installation (failure) + kickstart

Description of problem:

This is a regression compared to RHEL8.2 DVD.
When installing a system using the RHEL8.3 DVD connected to a USB port and a kickstart specifies "ignoredisk --only-use=sda" (where "sda" is the hard disk), the following error is seen and unattended installation is aborted:
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------
anaconda.log:14:30:23,312 WRN kickstart: Command cdrom will be parsed in DBus module.
[...]
anaconda.log:14:30:32,091 ERR payload.manager: PayloadError: Found no CD-ROM
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------

This seems due to having the DVD seen as "/dev/sdX" (e.g. /dev/sdb) hence being ignored/blacklisted.

The issue doesn't happen with RHEL8.2. With RHEL8.2, the anaconda.log message about "cdrom" stanza is not present, there is this instead:
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------
anaconda.log:14:52:04,797 DBG payload: Setting up cdrom install device
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------

Version-Release number of selected component (if applicable):

anaconda-33.16.3.26-1.el8


How reproducible:

ALWAYS

Steps to Reproduce:
1. Configure a VM to present the DVD as a USB CDROM

-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='[...]/rhel-8.3-x86_64-dvd.iso'/>
      <target dev='sdd' bus='usb'/>
      <readonly/>
      <boot order='1'/>
      <address type='usb' bus='0' port='4'/>
    </disk>
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------

2. Boot on the DVD and load the kickstart in attachment (ks.cfg in logs archive)

ks.cfg excerpt:
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------
ignoredisk --only-use=sda
clearpart --initlabel --drives=sda
-------- 8< ---------------- 8< ---------------- 8< ---------------- 8< --------


Actual results:

Unattended installation doesn't happen


Expected results:

Unattended installation happens

Comment 2 Jan Stodola 2021-01-19 12:52:28 UTC
As a workaround you can comment out the "cdrom" kickstart command and use the "harddrive" command instead:

harddrive --partition=sdX --dir=/

(change sdX to the name of the USB device, for example sdb).

Can you please confirm this workaround works for you?

Comment 3 Renaud Métrich 2021-01-19 13:27:55 UTC
Perfect, that works!

Comment 8 Jan Stodola 2021-01-26 19:18:36 UTC
*** Bug 1920574 has been marked as a duplicate of this bug. ***

Comment 21 haisun 2022-09-05 16:25:40 UTC
i think it's good to delete with cdrom, and we also need to see why is it error with this environment.

Comment 23 RHEL Program Management 2023-09-18 15:00:42 UTC
Issue migration from Bugzilla to Jira is in process at this time. This will be the last message in Jira copied from the Bugzilla bug.

Comment 24 RHEL Program Management 2023-09-18 15:02:31 UTC
This BZ has been automatically migrated to the issues.redhat.com Red Hat Issue Tracker. All future work related to this report will be managed there.

Due to differences in account names between systems, some fields were not replicated.  Be sure to add yourself to Jira issue's "Watchers" field to continue receiving updates and add others to the "Need Info From" field to continue requesting information.

To find the migrated issue, look in the "Links" section for a direct link to the new issue location. The issue key will have an icon of 2 footprints next to it, and begin with "RHEL-" followed by an integer.  You can also find this issue by visiting https://issues.redhat.com/issues/?jql= and searching the "Bugzilla Bug" field for this BZ's number, e.g. a search like:

"Bugzilla Bug" = 1234567

In the event you have trouble locating or viewing this issue, you can file an issue by sending mail to rh-issues. You can also visit https://access.redhat.com/articles/7032570 for general account information.