Bug 1915008

Summary: Fixed by revert -- Upgrade to OCP 4.6.9 (4.5.25) results in cluster-wide DNS and connectivity issues due to bad NetworkPolicy flows
Product: OpenShift Container Platform Reporter: Scott Dodson <sdodson>
Component: NetworkingAssignee: Dan Winship <danw>
Networking sub component: openshift-sdn QA Contact: zhaozhanqi <zzhao>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: medium CC: astoycos, bbennett, bleanhar, cblecker, danw, dmoessne, jminter, maschmid, palshure, rbohne, sdodson, skrenger, sreber, travi, wking, zzhao
Version: 4.5Keywords: ServiceDeliveryBlocker, Upgrades
Target Milestone: ---   
Target Release: 4.5.z   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
(Fixes a bug that never shipped in 4.5.z)
Story Points: ---
Clone Of: 1915007 Environment:
Last Closed: 2021-01-20 05:49:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1914284, 1915007    
Bug Blocks:    

Comment 1 Scott Dodson 2021-01-11 18:03:35 UTC
Please note that when testing this it was fixed by reverting the changes in bug 1904456, that bug has been moved back to ASSIGNED to be fixed in the future.

Comment 4 zhaozhanqi 2021-01-13 06:38:36 UTC
Verified this bug on 4.5.0-0.nightly-2021-01-12-085505 with steps https://bugzilla.redhat.com/show_bug.cgi?id=1914284#c11

Comment 6 errata-xmlrpc 2021-01-20 05:49:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.27 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0033

Comment 7 W. Trevor King 2021-03-31 04:18:45 UTC
Converting UpgradeBlocker to Upgrades per [1].

[1]: https://bugzilla.redhat.com/show_bug.cgi?id=1914284#c38