Bug 1917436

Summary: python-missingno: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Ankur Sinha (FranciscoD) <sanjay.ankur>
Component: python-missingnoAssignee: Ankur Sinha (FranciscoD) <sanjay.ankur>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: bazanluis20, neuro-sig, thrnciar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/python-missingno
Whiteboard:
Fixed In Version: python-missingno-0.4.2-7.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-24 19:42:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1915193, 1923247    
Bug Blocks: 1868278, 1890881    

Description Ankur Sinha (FranciscoD) 2021-01-18 13:38:33 UTC
Description of problem:
Package python-missingno fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.4.2-6.fc33

Steps to Reproduce:
koji build --scratch f34 python-missingno-0.4.2-6.fc33.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-missingno

Comment 1 Ankur Sinha (FranciscoD) 2021-01-18 14:08:30 UTC
Koschei says:

Problem: package python3-geoplot-0.4.1-3.fc33.noarch requires python3.9dist(geopandas), but none of the providers can be installed
- package python3-geopandas-0.8.1-3.fc33.noarch requires python3.9dist(fiona), but none of the providers can be installed
- conflicting requests
- nothing provides libgdal.so.27()(64bit) needed by python3-fiona-1.8.13-5.fc33.x86_64
Problem: package python3-geopandas-0.8.1-3.fc33.noarch requires python3.9dist(fiona), but none of the providers can be installed
- conflicting requests
- nothing provides libgdal.so.27()(64bit) needed by python3-fiona-1.8.13-5.fc33.x86_64


So it looks like it is a dep error. I'll look at it again to see if there's anything that can be done.

Comment 2 Ben Cotton 2021-02-09 15:41:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 34 development cycle.
Changing version to 34.

Comment 3 Fedora Update System 2021-04-04 02:51:54 UTC
FEDORA-2021-12479819ff has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-12479819ff

Comment 4 Fedora Update System 2021-04-05 01:39:54 UTC
FEDORA-2021-12479819ff has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-12479819ff`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-12479819ff

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-04-12 07:30:47 UTC
FEDORA-2021-12479819ff has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-12479819ff

Comment 6 Fedora Update System 2021-04-12 15:08:55 UTC
FEDORA-2021-12479819ff has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-12479819ff`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-12479819ff

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-04-24 19:42:42 UTC
FEDORA-2021-12479819ff has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2021-04-24 20:03:27 UTC
FEDORA-2021-12479819ff has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.