Bug 1917481

Summary: [BM][IPI] Master deployment failed: No valid host was found. Reason: No conductor service registered which supports driver redfish for conductor group
Product: OpenShift Container Platform Reporter: Derek Higgins <derekh>
Component: Bare Metal Hardware ProvisioningAssignee: Derek Higgins <derekh>
Bare Metal Hardware Provisioning sub component: ironic QA Contact: Lubov <lshilin>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: arivkin, beth.white, derekh, jhou, lshilin, mcornea, shardy, weinliu, ydalal, yprokule
Version: 4.6Keywords: Triaged
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously on some systems, the installer would communicate with ironic before it was ready and fail. This is now prevented.
Story Points: ---
Clone Of: 1902653
: 1945683 1945684 (view as bug list) Environment:
Last Closed: 2021-03-09 20:16:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1902653    
Bug Blocks: 1945683    

Comment 1 Dmitry Tantsur 2021-02-25 16:23:09 UTC
Raising priority since more and more people start hitting this, and there is no workaround.

Comment 4 Lubov 2021-03-01 13:58:33 UTC
verified on 4.6.0-0.nightly-2021-03-01-051748 - few runs, the issue not reproduced

Comment 6 errata-xmlrpc 2021-03-09 20:16:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.20 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0674

Comment 7 Alexey Rivkin 2021-04-01 14:48:22 UTC
Reproduced on versions 4.4 and 4.5
Shouldn't the fix be backported?
Please, advise.

Comment 8 Derek Higgins 2021-04-01 14:54:29 UTC
(In reply to Alexey Rivkin from comment #7)
> Reproduced on versions 4.4 and 4.5
> Shouldn't the fix be backported?
> Please, advise.

Yup, I should be able to backport, is there a bug open?

Comment 9 Alexey Rivkin 2021-04-01 16:06:55 UTC
Cloned the bug for versions 4.4 and 4.5:
BZ1945683, BZ1945684

Thanks!