Bug 1918510

Summary: [vsphere][ipi] directory path is incomplete, terraform can't find the cluster
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: InstallerAssignee: Jeremiah Stuever <jstuever>
Installer sub component: openshift-installer QA Contact: jima
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: adahiya, apurty, bleanhar, jima, jstuever, mabajodu, mstaeble, wking
Version: 4.5Keywords: Reopened
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-22 13:54:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1882022    
Bug Blocks:    

Comment 3 jima 2021-02-18 03:29:46 UTC
Verified on nightly build 4.6.0-0.nightly-2021-02-17-215814, installation is successful.

$ ./oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-02-17-215814   True        False         11m     Cluster version is 4.6.0-0.nightly-2021-02-17-215814

$ ./oc get machineset jstuevervcsa-nwlmx-worker -n openshift-machine-api -o json| jq -r .spec.template.spec.providerSpec.value.workspace
{
  "datacenter": "foo/SDDC-Datacenter",
  "datastore": "WorkloadDatastore",
  "folder": "/foo/SDDC-Datacenter/vm/jstuevervcsa-nwlmx",
  "resourcePool": "/foo/SDDC-Datacenter/host/bar/Cluster-1/Resources",
  "server": "jstuever-vcsa.vmc.devcluster.openshift.com"
}

Comment 5 errata-xmlrpc 2021-02-22 13:54:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0510