Bug 1921242

Summary: After Linux 5.8, wifi is extremely slow a few seconds after connecting
Product: [Fedora] Fedora Reporter: Daniel Farina <daniel>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 36CC: acaringi, adscvr, airlied, alciregi, bskeggs, hdegoede, itamar, jarodwilson, jeremy, jglisse, jonathan, josef, kernel-maint, lgoncalv, linville, masami256, mchehab, ptalbert, steved
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-05-17 16:07:51 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
dmesg for an unaffected boot
none
dmesg for an affected boot 5.10 none

Description Daniel Farina 2021-01-27 18:57:31 UTC
Created attachment 1751355 [details]
dmesg for an unaffected boot

Created attachment 1751355 [details]
dmesg for an unaffected boot

> 1. Please describe the problem:

I have a Dell XPS 15 with the following WiFi controller

3b:00.0 Network controller: Intel Corporation Wi-Fi 6 AX200 (rev 1a).

On newer kernels, my wifi is agonizingly slow a few seconds after connection.

> 2. What is the Version-Release number of the kernel:
> 3. Did it work previously in Fedora? If so, what kernel version did the issue
>   *first* appear?  Old kernels are available for download at
>   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

5.8.15-301.fc33.x86_64 seems to work.
5.10.10-200.fc33.x86_64 does not work.


> 4. Can you reproduce this issue? If so, please provide the steps to reproduce
>   the issue below:

1) Connect to WiFi (in my case, an 802.11ax on 5ghz)
2) Go to any speed testing site

After a few seconds, I will be getting from 10-120 kilobytes a second, which makes downloading old kernels agonizingly slow. Normally I can download megabytes in a second. I worked around it by toggling my rfkill button to get a few key seconds of full speed download.

> 5. Does this problem occur with the latest Rawhide kernel? To install the
>   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
>   ``sudo dnf update --enablerepo=rawhide kernel``:

Yes: 5.11.0-0.rc4.129.fc34.x86_64 #1 SMP Mon Jan 18 07:07:56 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

6. Are you running any modules that not shipped with directly Fedora's kernel?:

No

Comment 1 Daniel Farina 2021-01-27 19:27:10 UTC
Created attachment 1751361 [details]
dmesg for an affected boot 5.10

Comment 2 Daniel Farina 2021-02-13 16:47:33 UTC
I saw some iwl firmware updates go by, so I decided to give new (non-rawhide) kernels  another try.

Still having the problem. So I'm downgrading to 5.8 again.

5.10.14-200.fc33.x86_64 #1 SMP Sun Feb 7 19:59:31 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Daniel Farina 2021-02-24 21:57:30 UTC
I tried 5.10.16-200.fc33. Similar problem. It lasted somewhat longer, that could be chance, but eventually I could get no bytes through in a timely manner. 5.8.15-301.fc33.x86_64 never has a problem, I've been using it continuously except for my occasional few hours (tops) testing a new kernel.

Comment 4 Daniel Farina 2021-03-23 17:16:06 UTC
Still using 5.8 for weeks at a time where it acts normally. Saw a new kernel and IWL firmware update, and tried them out, 5.11.7-200.fc33. In a few minutes, wifi was unusable, a similar symptom as before.

Comment 5 Daniel Farina 2021-04-19 16:42:59 UTC
Tried out the newish 5.11.14-200.fc33. After a few minutes, same thing. Still no problems with 5.8.15-301.fc33 running for extended periods.

Comment 6 Daniel Farina 2021-05-03 18:07:43 UTC
Upgraded to Fedora 34, 5.11.17-300.fc34 carries the same defect. Still using 5.8.15-301.fc33.

Comment 7 Daniel Farina 2021-05-13 20:51:35 UTC
Tried out 5.11.19-300.fc34. Still a problem, though it took a few minutes to appear (this has happened on previous kernels, too). 5.8.15-301.fc33.x86_64 is still stable with wifi. I have noted in Fedora 34 that un-sleeping the laptop is no longer reliable, with either 5.8 or 5.11.

Comment 8 Daniel Farina 2021-06-04 01:38:55 UTC
Reproduced on 5.12.8-300.fc34

Comment 9 Daniel Farina 2021-06-25 17:21:20 UTC
Reproduced on 5.12.12-300.fc34

Comment 10 Daniel Farina 2021-07-24 00:07:52 UTC
I just spent a week on a different wifi network and I cannot reproduce this against a Linksys Velop mesh system (Wifi 6 5ghz) but I can against my usual Orbi mesh (also Wifi 6 5ghz).

Comment 11 Daniel Farina 2022-02-24 01:27:37 UTC
Reproduced on 5.15.18-200.fc35. I'm still using 5.8.15-301.fc33.x86_64 to make this laptop usable.

Comment 12 Ben Cotton 2022-05-12 15:37:53 UTC
This message is a reminder that Fedora Linux 34 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 34 on 2022-06-07.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '34'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 34 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 13 Daniel Farina 2022-05-17 16:07:51 UTC
This resolved to me. Perhaps a new kernel caused it, but I think much more likely is a relatively large set of firmware updates sent by Dell.