Bug 1923993

Summary: Imagepruner met error "Job has reached the specified backoff limit" which causes image registry degraded
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Image RegistryAssignee: Oleg Bulatov <obulatov>
Status: CLOSED ERRATA QA Contact: Wenjing Zheng <wzheng>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: aos-bugs, miabbott, scuppett, wking
Target Milestone: ---Keywords: Regression
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: the pruner were trying to detect the registry name using image streams Consequence: when there were no image streams, the pruner failed to detect the registry name Fix: the image registry operator provides the pruner with the registry name Result: the pruner does not depend on existence of image streams
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-09 20:16:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1887010    
Bug Blocks:    

Comment 1 Oleg Bulatov 2021-02-02 11:48:17 UTC
*** Bug 1923744 has been marked as a duplicate of this bug. ***

Comment 4 Wenjing Zheng 2021-03-03 03:24:44 UTC
Verified on 4.6.0-0.nightly-2021-03-01-051748:
    Args:
      adm
      prune
      images
      --confirm=true
      --certificate-authority=/var/run/configmaps/serviceca/service-ca.crt
      --keep-tag-revisions=3
      --keep-younger-than=60m
      --ignore-invalid-refs=true
      --loglevel=1
      --prune-registry=true
      --registry-url=https://image-registry.openshift-image-registry.svc:5000

Comment 6 errata-xmlrpc 2021-03-09 20:16:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.20 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0674