This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 192542

Summary: FC5 does not recognize a FC4 RAID0 install (cannot upgrade)
Product: [Fedora] Fedora Reporter: Ghassan Tchelepi <gtchelepi>
Component: anacondaAssignee: Peter Jones <pjones>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: bobgus, marceau.fedora, mozdiav, triage
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-24 10:48:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 150224    

Description Ghassan Tchelepi 2006-05-20 06:17:09 EDT
Description of problem:
 I was trying to upgrade from FC4 to FC5 using FC5 ISO DVD release. My FC4 
is/was a RAID 0 install (worked great), the FC5 upgrade did not recognize the
current FC4 RAID 0 install. It appears that FC5 was never tested for an upgrade
from FC4 RAID0 install. So I gave up on the upgrade hoping to
install FC5 but that did not work either (errno 256). Had to revert back to FC4.
I saw reports of errno 256 being reported, but it was not for an upgrade from
FC4 RAID0 install



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. FC4 RAID0  functioning install
2. Boot using FC5 ISO DVD release
3. 
  
Actual results:
Does not recognize FC4 RAID0 install

Expected results:
Upgrade to FC5


Additional info:
Comment 1 Bob Gustafson 2006-06-19 09:33:18 EDT
See also bug 186312

I had reported the problem differently in bug 189971, see that bug for history
of solution.

Solution is to disconnect all drives other than CD and raid disks from system.
This means firewire, USB, etc. These other drives confuse anaconda and the
result is that anaconda cannot see already configured raid arrays.
Comment 2 Jerry Marceau 2006-07-07 10:34:32 EDT
Hi Folks,

The solution in bug 189971 is not working for me.  I've got software raid0 set
up on two sata drives.  Fedora 4 rescue can see the partitions, but fedora 5
install and rescue can't.  /proc/partitions shows:

major  minor  #blocks     name
7       0     70420       loop0
8       0     195360984   sda
8       16    195360984   sdb
253     0     195312500   dm-0

No extra drives attached, and I've turned just about everything off in the bios,
still no luck.
Comment 3 Ghassan Tchelepi 2006-07-07 11:10:18 EDT
The only drives attached to my system (two SATA drive with FC4 raid0, One
CD-ROM, and One Floppy) The solution in bug 189971 does solve the problem.
Comment 4 Ghassan Tchelepi 2006-07-07 11:15:44 EDT
Correction Correction (Had a typo in comment #3) 


SHOULD BE --- >The solution in bug 189971 does NOT solve the problem.
SHOULD BE --- >The solution in bug 189971 does NOT solve the problem.
SHOULD BE --- >The solution in bug 189971 does NOT solve the problem.

The only drives attached to my system (two SATA drive with FC4 raid0, One
CD-ROM, and One Floppy) The solution in bug 189971 does NOT solve the problem.
Comment 5 Bug Zapper 2008-04-03 22:56:31 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 6 Joel Andres Granados 2008-04-24 10:48:35 EDT
This bug relates to unsupported versions of fedora.  Please reopen this bug if
you see this issue with currently supported versions of fedora.