Bug 1926340

Summary: Images from Private external registry not working in deploy Image
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: Mohammed Saud <msaud>
Severity: medium Docs Contact: Harsh Mishra <hmishra>
Priority: high    
Version: 4.6CC: adeshpan, aos-bugs, msaud, nmukherj
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, the pod did not start when the user added a secret for an external private container registry and imported the container image from the registry. As a result, the deployment was stuck until the service account or the deployment was updated manually. This bug fix allows the new deployments to use the internal container registry to start their pods. With this bug fix, the user can import a container image from an external private container registry without additional changes on the service account or the deployment.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-09 20:16:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1924955    
Bug Blocks:    

Comment 1 Christoph Jerolimov 2021-02-11 13:06:05 UTC
Set blocker to - because Severity is medium and there is no custom requested this.

Comment 2 Christoph Jerolimov 2021-02-22 15:02:34 UTC
*** Bug 1929182 has been marked as a duplicate of this bug. ***

Comment 5 Mohammed Saud 2021-03-05 07:24:24 UTC
Verified on:
Version: 4.6.0-0.nightly-2021-03-05-025530
Browsers: Firefox 85, Chromium 88

Comment 7 errata-xmlrpc 2021-03-09 20:16:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.20 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0674