Bug 1927628

Summary: kicad: FTBFS in Fedora rawhide
Product: [Fedora] Fedora Reporter: Tomáš Hrnčiar <thrnciar>
Component: kicadAssignee: Steven A. Falco <stevenfalco>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aimylios, alain.vigne.14, gmarr, ian.s.mcinerney, kiarakovalevsky, stevenfalco, thibault
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
URL: https://koschei.fedoraproject.org/package/kicad
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-12 19:33:52 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1927309, 1890881    

Description Tomáš Hrnčiar 2021-02-11 08:04:19 UTC
Description of problem:
Package kicad fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
5.1.9-2.fc34

Steps to Reproduce:
koji build --scratch f34 kicad-5.1.9-2.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/kicad

collect2: error: ld returned 1 exit status
gmake[2]: *** [qa/eeschema/CMakeFiles/qa_eeschema.dir/build.make:218: qa/eeschema/qa_eeschema] Error 1
gmake[2]: Leaving directory '/builddir/build/BUILD/kicad-5.1.9/x86_64-redhat-linux-gnu'
gmake[1]: *** [CMakeFiles/Makefile2:3130: qa/eeschema/CMakeFiles/qa_eeschema.dir/all] Error 2
gmake[1]: *** Waiting for unfinished jobs....
/builddir/build/BUILD/kicad-5.1.9/pcbnew/swig/python_scripting.cpp: In function 'bool pcbnewInitPythonScripting(const char*)':
/builddir/build/BUILD/kicad-5.1.9/pcbnew/swig/python_scripting.cpp:167:24: warning: 'void PyEval_InitThreads()' is deprecated [-Wdeprecated-declarations]
  167 |     PyEval_InitThreads();
      |                        ^
In file included from /usr/include/python3.9/Python.h:145,
                 from /builddir/build/BUILD/kicad-5.1.9/pcbnew/swig/python_scripting.h:37,
                 from /builddir/build/BUILD/kicad-5.1.9/pcbnew/swig/python_scripting.cpp:30:
/usr/include/python3.9/ceval.h:130:37: note: declared here
  130 | Py_DEPRECATED(3.9) PyAPI_FUNC(void) PyEval_InitThreads(void);
      |                                     ^~~~~~~~~~~~~~~~~~
In file included from /usr/include/boost/smart_ptr/detail/sp_thread_sleep.hpp:22,
                 from /usr/include/boost/smart_ptr/detail/yield_k.hpp:23,
                 from /usr/include/boost/smart_ptr/detail/spinlock_gcc_atomic.hpp:14,
                 from /usr/include/boost/smart_ptr/detail/spinlock.hpp:42,
                 from /usr/include/boost/smart_ptr/detail/spinlock_pool.hpp:25,
                 from /usr/include/boost/smart_ptr/shared_ptr.hpp:29,
                 from /usr/include/boost/shared_ptr.hpp:17,
                 from /usr/include/boost/date_time/microsec_time_clock.hpp:18,
                 from /usr/include/boost/interprocess/detail/posix_time_types_wrk.hpp:31,
                 from /usr/include/boost/interprocess/sync/interprocess_mutex.hpp:31,
                 from /builddir/build/BUILD/kicad-5.1.9/include/ki_mutex.h:39,
                 from /builddir/build/BUILD/kicad-5.1.9/pcbnew/footprint_preview_panel.cpp:32:
/usr/include/boost/bind.hpp:36:1: note: '#pragma message: The practice of declaring the Bind placeholders (_1, _2, ...) in the global namespace is deprecated. Please use <boost/bind/bind.hpp> + using namespace boost::placeholders, or define BOOST_BIND_GLOBAL_PLACEHOLDERS to retain the current behavior.'
   36 | BOOST_PRAGMA_MESSAGE(
      | ^~~~~~~~~~~~~~~~~~~~
/builddir/build/BUILD/kicad-5.1.9/pcbnew/tools/selection_tool.cpp: In member function 'int SELECTION_TOOL::findMove(const TOOL_EVENT&)':
/builddir/build/BUILD/kicad-5.1.9/pcbnew/tools/selection_tool.cpp:1324:14: warning: variable 'cursorPosition' set but not used [-Wunused-but-set-variable]
 1324 |         auto cursorPosition = viewCtrls->GetCursorPosition( false );
      |              ^~~~~~~~~~~~~~
gmake[2]: Leaving directory '/builddir/build/BUILD/kicad-5.1.9/x86_64-redhat-linux-gnu'
[ 98%] Built target pcbnew_kiface_objects
gmake[1]: Leaving directory '/builddir/build/BUILD/kicad-5.1.9/x86_64-redhat-linux-gnu'
gmake: *** [Makefile:185: all] Error 2

Comment 1 Ian McInerney 2021-02-11 11:24:25 UTC
Why is this blocking the Python 3.10 bug? The build failure is in the linking stage because of a symbol in ngspice, not Python.

Comment 2 Tomáš Hrnčiar 2021-02-11 14:24:52 UTC
It is there only for tracking purposes. We are rebuilding all Python packages in COPR and this way we know that breakage of the package is reported.

Comment 3 Steven A. Falco 2021-02-12 19:33:52 UTC
A new version of ngspice has been built [1] that corrects the problem.

[1] https://bodhi.fedoraproject.org/updates/FEDORA-2021-5be615eef0