This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 193096

Summary: cannot mount floppy disk
Product: [Fedora] Fedora Reporter: Chris Allen <ch.allen>
Component: gnome-volume-managerAssignee: John (J5) Palmieri <johnp>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: davidz, jkeck
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-29 21:35:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Chris Allen 2006-05-25 04:56:59 EDT
Description of problem:
Since upgrading from FC4 to FC5 I have not been able to mount a floppy disk.
There is no problem with CD/DVD's or with USB they mount automatically.
Only the floppy is a problem.

When I select the appropriate icon en error dialog box shows
"There are no filesystems which you are allowed to mount or unmount.
Contact your administrator."

I never had this problem with FC4

I notice some else had the problem but reolved this by "removing hal"
I'm not sure waht that means?.  I do have a directory /etc/hal/....


Version-Release number of selected component (if applicable):


How reproducible:
Every time I try to insert a floppy disk and mount it

Steps to Reproduce:
1.Insert floppy disk into drive
2.Select Icon for Disk Managment
3.
  
Actual results:
Dialog box with error message above appears


Expected results:


Additional info:
USB and DVD auto-mount every time with appropriate icons on the desk top
Comment 1 John (J5) Palmieri 2006-05-25 13:42:01 EDT
Check /etc/fstab and remove any entries with the managed option set.
Comment 2 Chris Allen 2006-05-26 04:50:10 EDT
Below is a copy of the file

$ cat fstab
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
/dev/devpts             /dev/pts                devpts  gid=5,mode=620  0 0
/dev/shm                /dev/shm                tmpfs   defaults        0 0
/dev/proc               /proc                   proc    defaults        0 0
/dev/sys                /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

I presume you refer to the 3rd line (about /dev/devpts).
Should I delete the line or change the 4th column to "default"?

Alternatively,
I see one of my books abpout this file includes the line
  /dev/fd0         /media/floppy   auto  noauto,owner    0 0
Should I add this line to the file?
If this is the solution, then presumably it was the before the upgrade
and the upgrade removed it. Why should this be so?
Comment 3 John (J5) Palmieri 2006-05-26 11:47:26 EDT
Hmm, ok so you are not experience the upgrade bug I was thinking of.  Your fstab
looks fine.  We don't list floppies anymore.
Comment 4 David Zeuthen 2006-05-26 11:50:15 EDT
Is this on KDE or GNOME?
Comment 5 Chris Allen 2006-05-27 00:48:57 EDT
I'm using GNOME Panel 2.24.0, as deleivered by the upgrade disk
Comment 6 John (J5) Palmieri 2006-05-28 17:16:58 EDT
GNOME Panel?  I'm guessing you are using the mount applet?  And I am guessing
the disk mounter applet was never updated to use gnome-mount.  Please confirm if
you are trying to mount from the panel as opposed to mounting from Nautilus.
Comment 7 David Zeuthen 2006-05-28 18:53:12 EDT
John, FYI the drive mount applet uses GNOME VFS (and so should g-v-m, it would
make life easier).
Comment 8 John (J5) Palmieri 2006-05-28 19:04:55 EDT
Hmm, looking at the code it does look correct.

Chris, you say you are up to date as of the update disk.  Have you also pulled
the latest updates from our servers?
Comment 9 Chris Allen 2006-05-29 04:59:30 EDT
We make progress.
My dektop has a menu bar at the top with standard options for "Applicataions",
"Places" & "System" plus icons for common applications.

With FC4 I coppied the icon for "Disk Management" from the standard menus to
this panel.  This icon remained there after the upgrade but no longer works. 
The prpoerties for this icon says the command is "usermount".  It presented a
list if divices I could mount/un-mount.  

Since the upgrade, I notoiced this icon has disappeared from the menus.

I have just searched the menus again and find a DIFFERNT icon in a DIFFERNT
loaction (My Computer) that does mount the floppy.  This icon looks like an
external floppy dive and is labeled Floppy Drive.

When this kind of upgrade changes the tools for basic operations it woulb be
nice for the old tools to advise what new alternatives should be used e.g.
"This tool (usermount) is no longer usable in this system
Look in My Computer for other options"
Comment 10 John (J5) Palmieri 2006-05-29 21:35:35 EDT
Great.  We do have release notes which should mark these changes.  However
things do get missed with the rapid release cycle.  I will be more diligent in
the future to note such changes.  Thank you.