Bug 1931957

Summary: kernel-core is not installable due to systemd-udev dropping /usr/bin/kernel-install
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 34CC: acaringi, adscvr, airlied, alciregi, bskeggs, hdegoede, jarodwilson, jeremy, jglisse, jonathan, josef, kernel-maint, kevin, lgoncalv, linville, masami256, mchehab, mtasaka, ptalbert, pwhalen, robatino, steved, zbyszek
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedBlocker
Fixed In Version: systemd-248~rc2-1.fc34 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-02-24 22:51:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1829022    

Description Adam Williamson 2021-02-23 16:21:35 UTC
See summary. Since systemd-248~rc1-1 showed up in F34 and Rawhide, kernel-core cannot be installed. This obviously breaks composes and so on, and so is an automatic Beta blocker per "Bugs which entirely prevent the composition of one or more of the release-blocking images required to be built for a currently-pending (pre-)release" - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers .

Not sure if systemd needs to put it back or kernel needs to adapt to its removal, filing against kernel for now.

Comment 1 Adam Williamson 2021-02-23 16:28:27 UTC
*** Bug 1931951 has been marked as a duplicate of this bug. ***

Comment 2 Adam Williamson 2021-02-23 21:12:28 UTC
Please don't close bugs against frozen releases like this. It is not fixed until the update goes stable.

Comment 3 Fedora Update System 2021-02-23 21:25:17 UTC
FEDORA-2021-965efe19ab has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-965efe19ab

Comment 4 Fedora Update System 2021-02-24 19:17:14 UTC
FEDORA-2021-965efe19ab has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-965efe19ab`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-965efe19ab

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2021-02-24 22:51:23 UTC
FEDORA-2021-965efe19ab has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.