Bug 193198

Summary: /usr/bin/pr -e file produces a glibc stack trace when file contains tabs
Product: [Fedora] Fedora Reporter: david kerns <dkerns>
Component: coreutilsAssignee: Tim Waugh <twaugh>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: meyering
Target Milestone: ---   
Target Release: ---   
Hardware: ia64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-26 06:37:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description david kerns 2006-05-25 19:39:30 EDT
Description of problem:
pr causes a stack backtrace
pr produces the correct output, but then is followed by this:

*** glibc detected *** pr: free(): invalid next size (fast): 0x000000000050e050 ***
======= Backtrace: =========
/lib64/libc.so.6[0x2aaaaad3bc43]
/lib64/libc.so.6(__libc_free+0x84)[0x2aaaaad3bdc4]
pr[0x404672]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x2aaaaaceae54]
pr[0x401a09]
======= Memory map: ========
00400000-0040c000 r-xp 00000000 fd:00 11126691                           /usr/bin/pr
0050c000-0050d000 rwxp 0000c000 fd:00 11126691                           /usr/bin/pr
0050d000-0052e000 rwxp 0050d000 00:00 0                                  [heap]
3a64d00000-3a64d0d000 r-xp 00000000 fd:00 10879209                      
/lib64/libgcc_s-4.1.0-20060304.so.1
3a64d0d000-3a64e0d000 ---p 0000d000 fd:00 10879209                      
/lib64/libgcc_s-4.1.0-20060304.so.1
3a64e0d000-3a64e0e000 rwxp 0000d000 fd:00 10879209                      
/lib64/libgcc_s-4.1.0-20060304.so.1
2aaaaaaab000-2aaaaaac5000 r-xp 00000000 fd:00 10879095                  
/lib64/ld-2.4.so
2aaaaaac5000-2aaaaaac6000 rwxp 2aaaaaac5000 00:00 0 
2aaaaaad9000-2aaaaaada000 rwxp 2aaaaaad9000 00:00 0 
2aaaaabc4000-2aaaaabc5000 r-xp 00019000 fd:00 10879095                  
/lib64/ld-2.4.so
2aaaaabc5000-2aaaaabc6000 rwxp 0001a000 fd:00 10879095                  
/lib64/ld-2.4.so
2aaaaabc6000-2aaaaabcd000 r-xp 00000000 fd:00 10879015                  
/lib64/librt-2.4.so
2aaaaabcd000-2aaaaaccc000 ---p 00007000 fd:00 10879015                  
/lib64/librt-2.4.so
2aaaaaccc000-2aaaaaccd000 r-xp 00006000 fd:00 10879015                  
/lib64/librt-2.4.so
2aaaaaccd000-2aaaaacce000 rwxp 00007000 fd:00 10879015                  
/lib64/librt-2.4.so
2aaaaacce000-2aaaaae0d000 r-xp 00000000 fd:00 10878987                  
/lib64/libc-2.4.so
2aaaaae0d000-2aaaaaf0d000 ---p 0013f000 fd:00 10878987                  
/lib64/libc-2.4.so
2aaaaaf0d000-2aaaaaf11000 r-xp 0013f000 fd:00 10878987                  
/lib64/libc-2.4.so
2aaaaaf11000-2aaaaaf12000 rwxp 00143000 fd:00 10878987                  
/lib64/libc-2.4.so
2aaaaaf12000-2aaaaaf17000 rwxp 2aaaaaf12000 00:00 0 
2aaaaaf17000-2aaaaaf29000 r-xp 00000000 fd:00 10879011                  
/lib64/libpthread-2.4.so
2aaaaaf29000-2aaaab029000 ---p 00012000 fd:00 10879011                  
/lib64/libpthread-2.4.so
2aaaab029000-2aaaab02a000 r-xp 00012000 fd:00 10879011                  
/lib64/libpthread-2.4.so
2aaaab02a000-2aaaab02b000 rwxp 00013000 fd:00 10879011                  
/lib64/libpthread-2.4.so
2aaaab02b000-2aaaab031000 rwxp 2aaaab02b000 00:00 0 
2aaaab031000-2aaaae400000 r-xp 00000000 fd:00 11111337                  
/usr/lib/locale/locale-archive
2aaaae401000-2aaaae408000 r-xs 00000000 fd:00 11174845                  
/usr/lib64/gconv/gconv-modules.cache
2aaaae408000-2aaaae409000 rwxp 2aaaae408000 00:00 0 
2aaaae500000-2aaaae521000 rwxp 2aaaae500000 00:00 0 
2aaaae521000-2aaaae600000 ---p 2aaaae521000 00:00 0 
7fffffe76000-7fffffe8b000 rw-p 7fffffe76000 00:00 0                      [stack]
ffffffffff600000-ffffffffffe00000 ---p 00000000 00:00 0                  [vdso]


Version-Release number of selected component (if applicable):

$ rpm -qf /usr/bin/pr
coreutils-5.93-7.2
$ uname -a
Linux lxdev01.corp.westell.com 2.6.16-1.2122_FC5 #1 SMP Sun May 21 15:01:10 EDT
2006 x86_64

How reproducible:
every time

Steps to Reproduce:
1. create a file with 2 lines, have 1 line start with a <tab>
2. pr -e file
  
Actual results:

see above

Expected results:

tabs expanded to spaces

Additional info:
Comment 1 petrosyan 2006-05-25 20:55:12 EDT
this is a duplicate of bug #192381
Comment 2 Tim Waugh 2006-05-26 06:37:51 EDT

*** This bug has been marked as a duplicate of 192381 ***