Bug 1933140

Summary: prusa-slicer breaks openvdb upgrade on F32
Product: [Fedora] Fedora Reporter: J. Randall Owens <jrowens.fedora>
Component: openvdbAssignee: Simone Caronni <negativo17>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 32CC: j, luya_tfz, mhroncok, negativo17, sbroz
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-03-02 15:34:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description J. Randall Owens 2021-02-25 19:07:29 UTC
Description of problem:
Current prusa-slicer release depends on libopenvdb.so.7.0, but the new openvdb-libs-8.0.1-1.fc32 provides libopenvdb.so.8.0, so it can't be updated.

Version-Release number of selected component (if applicable):
prusa-slicer-2.2.0-1.fc32

How reproducible:
Fairly easily

Steps to Reproduce:
1. Install prusa-slicer-2.2.0-1.fc32 & openvdb-libs-7.0.0-2.fc32 (maybe by downgrade if needed)
2. dnf upgrade

Actual results:
 Problem 1: package prusa-slicer-2.2.0-1.fc32.x86_64 requires libopenvdb.so.7.0()(64bit), but none of the providers can be installed
  - cannot install both openvdb-libs-8.0.1-1.fc32.x86_64 and openvdb-libs-7.0.0-7.fc32.x86_64
  - cannot install both openvdb-libs-7.0.0-2.fc32.x86_64 and openvdb-libs-8.0.1-1.fc32.x86_64
  - cannot install the best update candidate for package prusa-slicer-2.2.0-1.fc32.x86_64
  - cannot install the best update candidate for package openvdb-libs-7.0.0-7.fc32.x86_64
Problem 3: problem with installed package prusa-slicer-2.2.0-1.fc32.x86_64
  - package prusa-slicer-2.2.0-1.fc32.x86_64 requires libopenvdb.so.7.0()(64bit), but none of the providers can be installed
  - cannot install both openvdb-libs-8.0.1-1.fc32.x86_64 and openvdb-libs-7.0.0-7.fc32.x86_64
  - cannot install both openvdb-libs-8.0.1-1.fc32.x86_64 and openvdb-libs-7.0.0-2.fc32.x86_64
  - cannot install both openvdb-libs-7.0.0-2.fc32.x86_64 and openvdb-libs-8.0.1-1.fc32.x86_64
  - package openvdb-8.0.1-1.fc32.x86_64 requires libopenvdb.so.8.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package openvdb-7.0.0-7.fc32.x86_64
etc.

Expected results:
upgrade with shiny new OpenVDB

Additional info:
Please do check on F33, also.

Comment 1 Miro Hrončok 2021-02-25 19:14:53 UTC
Seems like openvdb was updated in Fedora 32 https://bodhi.fedoraproject.org/updates/FEDORA-2021-13fb385824 to an incompatible version.

Comment 2 Miro Hrončok 2021-02-25 19:20:00 UTC
$ repoquery --releasever=32 --repo={fedora,updates{,-testing}} --latest=1 --whatrequires 'libopenvdb.so.7.0()(64bit)'
OpenImageIO-0:2.1.11.1-1.fc32.x86_64
blender-1:2.83.9-1.fc32.x86_64
openvdb-0:7.0.0-2.fc32.x86_64
openvdb-devel-0:7.0.0-2.fc32.x86_64
prusa-slicer-0:2.2.0-1.fc32.x86_64
python3-openvdb-0:7.0.0-2.fc32.x86_64

$ repoquery --releasever=33 --repo={fedora,updates{,-testing}} --latest=1 --whatrequires 'libopenvdb.so.7.0()(64bit)'
OpenImageIO-0:2.1.18.1-1.fc33.x86_64
blender-1:2.90.1-1.fc33.x86_64
openvdb-0:7.0.0-11.fc33.x86_64
openvdb-devel-0:7.0.0-11.fc33.x86_64
prusa-slicer-0:2.2.0-4.fc33.x86_64
python3-openvdb-0:7.0.0-11.fc33.x86_64

Comment 3 Miro Hrončok 2021-02-25 19:31:36 UTC
prusa-slicer rebuild attempts:

https://src.fedoraproject.org/rpms/prusa-slicer/pull-request/5
https://src.fedoraproject.org/rpms/prusa-slicer/pull-request/6

Not sure if any other package is affected.

Comment 4 J. Randall Owens 2021-02-25 19:43:08 UTC
(In reply to Miro Hrončok from comment #2)
> $ repoquery --releasever=32 --repo={fedora,updates{,-testing}} --latest=1
> --whatrequires 'libopenvdb.so.7.0()(64bit)'
> OpenImageIO-0:2.1.11.1-1.fc32.x86_64
> blender-1:2.83.9-1.fc32.x86_64
> openvdb-0:7.0.0-2.fc32.x86_64
> openvdb-devel-0:7.0.0-2.fc32.x86_64
> prusa-slicer-0:2.2.0-1.fc32.x86_64
> python3-openvdb-0:7.0.0-2.fc32.x86_64
> 
> $ repoquery --releasever=33 --repo={fedora,updates{,-testing}} --latest=1
> --whatrequires 'libopenvdb.so.7.0()(64bit)'
> OpenImageIO-0:2.1.18.1-1.fc33.x86_64
> blender-1:2.90.1-1.fc33.x86_64
> openvdb-0:7.0.0-11.fc33.x86_64
> openvdb-devel-0:7.0.0-11.fc33.x86_64
> prusa-slicer-0:2.2.0-4.fc33.x86_64
> python3-openvdb-0:7.0.0-11.fc33.x86_64

Note however that in F32, OpenImageIO-2.1.20.0-2.fc32.x86_64, and of course those openvdb variants/subpackages, have been updated and requires libopenvdb.so.8.0()(64bit). It looks like it's just prusa-slicer and blender on my system holding it back, and I'm hoping bug #1918303 will take care of the other along the way.

Comment 5 Fedora Update System 2021-02-26 11:12:34 UTC
FEDORA-2021-13c033a187 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2021-13c033a187

Comment 6 Fedora Update System 2021-02-27 00:00:24 UTC
FEDORA-2021-cd2d8b6cc8 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-cd2d8b6cc8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-cd2d8b6cc8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-02-27 00:18:34 UTC
FEDORA-2021-13c033a187 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-13c033a187`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-13c033a187

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Stepan Broz 2021-02-27 13:39:06 UTC
FYI, a similar openvdb update breaks prusa-slicer on F33 too.

$ sudo dnf update
Last metadata expiration check: 0:45:40 ago on So 27. února 2021, 13:50:27.
Dependencies resolved.

 Problem 1: package prusa-slicer-2.2.0-4.fc33.x86_64 requires libopenvdb.so.7.0()(64bit), but none of the providers can be installed
  - cannot install both openvdb-libs-8.0.1-1.fc33.x86_64 and openvdb-libs-7.0.0-11.fc33.x86_64
  - cannot install both openvdb-libs-7.0.0-11.fc33.x86_64 and openvdb-libs-8.0.1-1.fc33.x86_64
  - cannot install the best update candidate for package prusa-slicer-2.2.0-4.fc33.x86_64
  - cannot install the best update candidate for package openvdb-libs-7.0.0-11.fc33.x86_64
 Problem 2: problem with installed package prusa-slicer-2.2.0-4.fc33.x86_64
  - package prusa-slicer-2.2.0-4.fc33.x86_64 requires libopenvdb.so.7.0()(64bit), but none of the providers can be installed
  - cannot install both openvdb-libs-8.0.1-1.fc33.x86_64 and openvdb-libs-7.0.0-11.fc33.x86_64
  - cannot install both openvdb-libs-7.0.0-11.fc33.x86_64 and openvdb-libs-8.0.1-1.fc33.x86_64
  - package OpenImageIO-2.2.11.1-1.fc33.1.x86_64 requires libopenvdb.so.8.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package OpenImageIO-2.2.10.0-1.fc33.x86_64
========================================================================================================================================
 Package                          Architecture               Version                                  Repository                   Size
========================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 openvdb-libs                     x86_64                     8.0.1-1.fc33                             updates                     770 k
Skipping packages with broken dependencies:
 OpenImageIO                      x86_64                     2.2.11.1-1.fc33.1                        updates                     2.3 M

Transaction Summary
========================================================================================================================================
Skip  2 Packages

Nothing to do.

Comment 9 Stepan Broz 2021-02-27 13:49:27 UTC
Ah, haven't spotted the F33 advisory FEDORA-2021-cd2d8b6cc8 that fixes the issue for me. 

Thank you!

Comment 10 Fedora Update System 2021-02-27 22:18:14 UTC
FEDORA-2021-cd2d8b6cc8 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Miro Hrončok 2021-03-01 14:04:18 UTC
Reopening for Fedora 32, the update there is still in testing.

Comment 12 Fedora Update System 2021-03-02 15:34:59 UTC
FEDORA-2021-13c033a187 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.