Bug 1933624

Summary: [4.6] The infra index filled with warnings "WARNING: kubernetes.io/cinder built-in volume provider is now deprecated. The Cinder volume provider is deprecated and will be removed in a future release"
Product: OpenShift Container Platform Reporter: Jan Safranek <jsafrane>
Component: StorageAssignee: Jan Safranek <jsafrane>
Storage sub component: Kubernetes QA Contact: Wei Duan <wduan>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: medium CC: aos-bugs, eparis, jokerman, jsafrane, piqin, ssadhale, wduan
Version: 4.5   
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1895329 Environment:
Last Closed: 2021-03-30 17:03:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1895329    
Bug Blocks:    

Description Jan Safranek 2021-03-01 09:48:50 UTC
+++ This bug was initially created as a clone of Bug #1895329 +++

Description of problem:
The infra index is filled with WARNING messages as follows: 

WARNING: kubernetes.io/cinder built-in volume provider is now deprecated. The Cinder volume provider is deprecated and will be removed in a future release


Environment:
OCP 4.5.16 on OSP

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install ClusterLogging on OSP
2. Check the infra index 

$ oc-es-exec es_util '--query=infra-indexname/_count?q=message:The+Cinder+volume+provider+is+deprecated+and+will+be+removed+in+a+future' | jq .count -r

111833647

Actual results:
The index has almost 20% lines with those log lines. It creates a lot of noise.

Expected results:
The warning messages should be removed as it creates issues when analyzing the logs via Kibana.

Additional info:

--- Additional comment from Saurabh Sadhale on 2021-02-26 04:09:44 UTC ---

@Jan I have the following from the customer regarding backport. Please check and let us know the Bugzilla number for OCP 4.6 backport. 

I think we must have upgraded to 4.6 since I opened this case, so actaully the ask is for a 4.6 backport now. Purely because we won't be upgrading to 4.7 for a while :)

Comment 2 Wei Duan 2021-03-22 03:22:02 UTC
Verified pass on 4.6.0-0.nightly-2021-03-21-131139

Currently, we can see once at the beginning of the kcm log: 
$ for i in `seq 0 2`; do oc logs kube-controller-manager-wduan0322c-7l5hs-master-$i | grep "provider is now deprecated";done
W0322 02:08:09.813929       1 plugins.go:105] WARNING: openstack built-in cloud provider is now deprecated. Please use 'external' cloud provider for openstack: https://github.com/kubernetes/cloud-provider-openstack
W0322 02:08:11.383296       1 plugins.go:731] WARNING: kubernetes.io/cinder built-in volume provider is now deprecated. The Cinder volume provider is deprecated and will be removed in a future release
W0322 01:51:43.356917       1 plugins.go:105] WARNING: openstack built-in cloud provider is now deprecated. Please use 'external' cloud provider for openstack: https://github.com/kubernetes/cloud-provider-openstack
W0322 01:51:44.546291       1 plugins.go:731] WARNING: kubernetes.io/cinder built-in volume provider is now deprecated. The Cinder volume provider is deprecated and will be removed in a future release
W0322 02:05:08.539599       1 plugins.go:105] WARNING: openstack built-in cloud provider is now deprecated. Please use 'external' cloud provider for openstack: https://github.com/kubernetes/cloud-provider-openstack
W0322 02:05:09.509056       1 plugins.go:731] WARNING: kubernetes.io/cinder built-in volume provider is now deprecated. The Cinder volume provider is deprecated and will be removed in a future release

Comment 5 errata-xmlrpc 2021-03-30 17:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0952