Bug 1933727

Summary: User with edit users cannot deploy images from their own namespace from the developer perspective - 4.6
Product: OpenShift Container Platform Reporter: Karthik Jeeyar <kjeeyar>
Component: Dev ConsoleAssignee: Karthik Jeeyar <kjeeyar>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: high Docs Contact: Harsh Mishra <hmishra>
Priority: high    
Version: 4.6CC: aballant, aos-bugs, gamore, hmishra, jakumar, joboyer, karsharm, kjeeyar, nmukherj, openshift-bugs-escalate, shsaxena, sparpate, spathak, viraj, wsun, yhuang
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, the user was denied access to pull images from other projects due to insufficient user permissions. This bug fix removes all the user interface checks for role bindings and shows the `oc` command alert to help users use the command line. With this bug fix, the user is no longer blocked from creating images from different namespaces and is now able to deploy images from other projects.
Story Points: ---
Clone Of: 1894020 Environment:
Last Closed: 2021-03-16 23:22:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1894020    
Bug Blocks:    
Attachments:
Description Flags
User with edit users can deploy images from their own namespace from the developer perspective - 4.6 none

Comment 3 spathak@redhat.com 2021-03-04 08:42:14 UTC
Created attachment 1760631 [details]
User with edit users can deploy images from their own namespace from the developer perspective - 4.6

Comment 4 spathak@redhat.com 2021-03-04 08:43:00 UTC
Verified on build version: 4.6.0-0.nightly-2021-03-04-040959
Browser version: Chrome 84

Comment 7 errata-xmlrpc 2021-03-16 23:22:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.21 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0753