Bug 1935249

Summary: Some changes of qga command "get-devices" should be fix on mingw-qemu-ga-win to qemu 5.2 [rhel-8.5.0]
Product: Red Hat Enterprise Linux 8 Reporter: RHEL Program Management Team <pgm-rhel-tools>
Component: virtio-winAssignee: Basil Salman <bsalman>
virtio-win sub component: qemu-ga-win QA Contact: dehanmeng <demeng>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified CC: ailan, bsalman, juzhang, lijin, lmiksik, mdean, yvugenfi
Version: 8.4Keywords: Rebase, Reopened, Triaged
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Windows   
Whiteboard:
Fixed In Version: mingw-qemu-ga-win-102.2.0-2.el8 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1920874 Environment:
Last Closed: 2021-11-09 18:52:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1920874    
Bug Blocks:    

Comment 3 Yvugenfi@redhat.com 2021-06-17 11:23:07 UTC
The fix in mingw-qemu-ga-win-102.4.0-0.el8

Comment 4 dehanmeng 2021-06-18 02:34:51 UTC
Verify with this latest build qemu-ga-win-102.4.0-0.el8.noarch.rpm

version:
kernel-4.18.0-312.el8.x86_64
qemu-ga-win-102.4.0-0.el8.noarch.rpm
qemu-kvm-docs-6.0.0-19.module+el8.5.0+11385+6e7d542e.x86_64
RHEL-8.5.0-20210611.n.0

step to verify:
1. boot up win2016 guest with serial and qga.
2. connect with guest and execute qga command.

Actually result:
{"execute":"guest-get-devices"}
{"return": [{"driver-date": 1621123200000000000, "driver-name": "Red Hat VirtIO SCSI pass-through controller", "driver-version": "100.85.104.19900", "id": {"device-id": 4168, "vendor-id": 6900, "type": "pci"}}, {"driver-date": 1621123200000000000, "driver-name": "Red Hat VirtIO Ethernet Adapter #2", "driver-version": "100.85.104.19900", "id": {"device-id": 4161, "vendor-id": 6900, "type": "pci"}}, {"driver-date": 1621123200000000000, "driver-name": "VirtIO Serial Driver", "driver-version": "100.85.104.19900", "id": {"device-id": 4163, "vendor-id": 6900, "type": "pci"}}]}

Expected result as above.

Comment 7 errata-xmlrpc 2021-11-09 18:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (virtio-win bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2021:4341