Bug 1940453

Summary: catalog operator causing CPU spikes and bad etcd performance
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: OLMAssignee: Ben Luddy <bluddy>
OLM sub component: OLM QA Contact: xzha
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: high CC: bluddy, jdelft, oarribas
Version: 4.6Keywords: Triaged
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-20 19:27:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1938405    
Bug Blocks:    

Comment 2 xzha 2021-03-26 05:38:08 UTC
verify:

zhaoxia@xia-MacBook-Pro test % oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-03-25-094616   True        False         168m    Cluster version is 4.6.0-0.nightly-2021-03-25-094616

zhaoxia@xia-MacBook-Pro test % oc get catsrc -A
NAMESPACE               NAME                  DISPLAY                TYPE   PUBLISHER      AGE
openshift-marketplace   certified-operators   Certified Operators    grpc   Red Hat        3h13m
openshift-marketplace   community-operators   Community Operators    grpc   Red Hat        3h13m
openshift-marketplace   etcd-test-1           Jian Test              grpc   Jian           127m
openshift-marketplace   etcd-test-10          Jian Test              grpc   Jian           123m
openshift-marketplace   etcd-test-11          Jian Test              grpc   Jian           123m
openshift-marketplace   etcd-test-12          Jian Test              grpc   Jian           122m
openshift-marketplace   etcd-test-2           Jian Test              grpc   Jian           126m
openshift-marketplace   etcd-test-3           Jian Test              grpc   Jian           126m
openshift-marketplace   etcd-test-4           Jian Test              grpc   Jian           126m
openshift-marketplace   etcd-test-5           Jian Test              grpc   Jian           125m
openshift-marketplace   etcd-test-6           Jian Test              grpc   Jian           125m
openshift-marketplace   etcd-test-7           Jian Test              grpc   Jian           124m
openshift-marketplace   etcd-test-8           Jian Test              grpc   Jian           124m
openshift-marketplace   qe-app-registry       Production Operators   grpc   OpenShift QE   169m
openshift-marketplace   redhat-marketplace    Red Hat Marketplace    grpc   Red Hat        3h13m
openshift-marketplace   redhat-operators      Red Hat Operators      grpc   Red Hat        3h13m
zhaoxia@xia-MacBook-Pro test % oc get sub -A
NAMESPACE   NAME   PACKAGE   SOURCE         CHANNEL
default     etcd   etcd      etcd-test-2    4.6
test-1      etcd   etcd      etcd-test-3    4.6
test-2      etcd   etcd      etcd-test-4    4.6
test-3      etcd   etcd      etcd-test-11   4.6
test-4      etcd   etcd      etcd-test-6    4.6
test-5      etcd   etcd      etcd-test-10   4.6
test-6      etcd   etcd      etcd-test-6    4.6
test-7      etcd   etcd      etcd-test-8    4.6
test-8      etcd   etcd      etcd-test-1    4.6
test-9      etcd   etcd      etcd-test-12   4.6

monitor CPU usage

https://user-images.githubusercontent.com/77608951/112587272-47de5d00-8e38-11eb-842f-344f2f64a087.png
 
there is no significant cpu consumption.

LGTM, verified

Comment 8 errata-xmlrpc 2021-04-20 19:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.25 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1153