Bug 1941563

Summary: High RAM usage on machine api termination node system oom
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Cloud ComputeAssignee: Joel Speed <jspeed>
Cloud Compute sub component: Other Providers QA Contact: Milind Yadav <miyadav>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: aos-bugs, jdelft
Version: 4.7   
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: HTTP requests were not being closed once they were no longer needed Consequence: In Go, this leaks go routines which over time, increases memory usage Fix: Ensure that the HTTP request is always closed when it is no longer needed Result: Memory usage is now stable in termination handlers
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-20 19:27:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1935636    
Bug Blocks:    

Comment 2 Milind Yadav 2021-03-29 04:38:53 UTC
Validated details below :



[miyadav@miyadav aws]$ kubectl top pod 
NAME                                           CPU(cores)   MEMORY(bytes)   
cluster-autoscaler-operator-5464c4b7b7-jzjbm   0m           32Mi            
machine-api-controllers-84464f8875-qcnxc       0m           110Mi           
machine-api-operator-69c9bcf67c-lvrr6          0m           38Mi            
machine-api-termination-handler-9dm6q          0m           14Mi            
[miyadav@miyadav aws]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2021-03-27-052141   True        False         37m     Cluster version is 4.6.0-0.nightly-2021-03-27-052141
[miyadav@miyadav aws]$ 


Additional info :

Spinned a spot instance in AWS  to get the machine-handler pod up ...
Moved to verified

Comment 8 errata-xmlrpc 2021-04-20 19:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.25 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1153