Bug 1941634

Summary: users can see metrics of namespaces for which they don't have rights when monitoring own services with prometheus user workloads
Product: OpenShift Container Platform Reporter: Simon Pasquier <spasquie>
Component: MonitoringAssignee: Jayapriya Pai <janantha>
Status: CLOSED ERRATA QA Contact: hongyan li <hongyli>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.6CC: aivaras.laimikis, alegrand, anpicker, erooth, gparente, hongyli, juzhao, kakkoyun, lcosic, mas-hatada, mfuruta, pkrupa, rh-container, spasquie
Target Milestone: ---Keywords: EasyFix
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1913386 Environment:
Last Closed: 2021-06-29 06:26:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1913386    
Bug Blocks:    

Comment 6 Junqi Zhao 2021-06-21 03:44:41 UTC
tested with 4.6.0-0.nightly-2021-06-19-165544, user can only view its metrics under their own project

Comment 9 errata-xmlrpc 2021-06-29 06:26:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.36 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2498