Bug 1942055

Summary: [sig-cluster-lifecycle] Cluster version operator acknowledges upgrade : timed out waiting for cluster to acknowledge upgrade
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: Cluster Version OperatorAssignee: Jack Ottofaro <jack.ottofaro>
Status: CLOSED ERRATA QA Contact: liujia <jiajliu>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.7CC: aos-bugs, jack.ottofaro, jiajliu, jokerman, lmohanty, pmahajan, vrutkovs, wking
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
This change is an additional log output in a CI test.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-12 23:22:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1909875    
Bug Blocks:    

Comment 3 liujia 2021-04-06 09:26:30 UTC
From ci test results in past 48h, there are not failures post 4.6.

# w3m -dump -cols 200 'https://search.ci.openshift.org/?search=Cluster+version+operator+acknowledges+upgrade&maxAge=48h&context=1&type=junit&name=&excludeName=&maxMatches=5&maxBytes=20971520&groupBy=job'|grep 'failures match'
periodic-ci-openshift-release-master-ci-4.5-upgrade-from-stable-4.4-e2e-gcp-upgrade (all) - 8 runs, 38% failed, 67% of failures match = 25% impact 
-> 4.4-4.5 upgrade
periodic-ci-openshift-release-master-ci-4.5-upgrade-from-stable-4.4-e2e-aws-upgrade (all) - 10 runs, 50% failed, 60% of failures match = 30% impact
-> 4.4-4.5 upgrade
periodic-ci-openshift-release-master-ci-4.5-upgrade-from-stable-4.4-e2e-azure-ovn-upgrade (all) - 8 runs, 63% failed, 40% of failures match = 25% impact
-> 4.4-4.5 upgrade
periodic-ci-openshift-release-master-ci-4.7-upgrade-from-stable-4.6-e2e-openstack-upgrade (all) - 1 runs, 100% failed, 100% of failures match = 100% impact
-> 4.6-4.7 upgrade, and the error(Get "https://api.9z3vdzkt-0a3c5.shiftstack.devcluster.openshift.com:6443/apis/config.openshift.io/v1/clusterversions/version": dial tcp 128.31.25.249:6443: connect: connection refused) is differenct from original error(timed out waiting for cluster to acknowledge upgrade: timed out waiting for the condition
)
release-openshift-origin-installer-e2e-aws-upgrade (all) - 11 runs, 55% failed, 33% of failures match = 18% impact
-> 4.4-4.5 upgrade
periodic-ci-openshift-release-master-ci-4.6-upgrade-from-stable-4.5-e2e-aws-ovn-upgrade (all) - 21 runs, 100% failed, 19% of failures match = 19% impact
-> 4.5-4.6 upgrade
periodic-ci-openshift-release-master-ci-4.6-upgrade-from-stable-4.5-e2e-aws-upgrade (all) - 22 runs, 50% failed, 27% of failures match = 14% impact
-> 4.5-4.6 upgrade
release-openshift-origin-installer-e2e-gcp-ovn-upgrade-4.5-stable-to-4.6-ci (all) - 8 runs, 50% failed, 50% of failures match = 25% impact
-> 4.5-4.6 upgrade
periodic-ci-openshift-release-master-ci-4.5-upgrade-from-stable-4.4-e2e-azure-upgrade (all) - 8 runs, 25% failed, 100% of failures match = 25% impact
-> 4.4-4.5 upgrade
periodic-ci-openshift-release-master-ci-4.5-upgrade-from-stable-4.4-e2e-gcp-ovn-upgrade (all) - 8 runs, 50% failed, 25% of failures match = 13% impact

So move this bug to verify.

-> 4.4-4.5 upgrade
periodic-ci-openshift-release-master-ci-4.6-upgrade-from-stable-4.5-e2e-azure-upgrade (all) - 9 runs, 44% failed, 25% of failures match = 11% impact
-> 4.5-4.6 upgrade

Comment 5 errata-xmlrpc 2021-04-12 23:22:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1075