Bug 1942862

Summary: kuryr-cni binds to wrong interface on machine with two interfaces
Product: OpenShift Container Platform Reporter: OpenShift BugZilla Robot <openshift-bugzilla-robot>
Component: NetworkingAssignee: MichaƂ Dulko <mdulko>
Networking sub component: kuryr QA Contact: Jon Uriarte <juriarte>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: high CC: jdelft, juriarte, ltomasbo, rlobillo
Version: 4.6.z   
Target Milestone: ---   
Target Release: 4.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-04-20 19:27:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1928028    
Bug Blocks:    
Attachments:
Description Flags
Conformance tests results with the fix none

Comment 3 Jon Uriarte 2021-03-30 13:55:05 UTC
Verified in 4.6.0-0.nightly-2021-03-27-052141 on top of OSP 16.1.4 (RHOS-16.1-RHEL-8-20210311.n.1) with OVN-Octavia.

link_iface attribute is not harcoded on kuryr.conf anymore on kuryr-cni pod running on the worker.

$ oc debug nodes/ostest-dtxfw-worker-0-2ngrt
Creating debug namespace/openshift-debug-node-j8lgb ...
Starting pod/ostest-dtxfw-worker-0-2ngrt-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.196.0.218
If you don't see a command prompt, try pressing enter.
sh-4.4# chroot /host
sh-4.4# sudo crictl ps -a | grep kuryr-cni
fe29a58337c39       519fed3a035164c8813a5ee4e6a41fc2a43030bed661ddbcfa1e06e90b08cb37                                                             16 hours ago         Running             kuryr-cni                      2                   30ef4b9e9bd78
878972c270c87       519fed3a035164c8813a5ee4e6a41fc2a43030bed661ddbcfa1e06e90b08cb37                                                             16 hours ago         Exited              kuryr-cni                      1                   30ef4b9e9bd78
sh-4.4# sudo crictl exec -it fe29a58337c39 cat /etc/kuryr/kuryr.conf | grep link_iface
sh-4.4# 

Conformance tests passed successfully as well, find the logs attached.

Comment 4 Jon Uriarte 2021-03-30 13:56:04 UTC
Created attachment 1767688 [details]
Conformance tests results with the fix

Comment 11 errata-xmlrpc 2021-04-20 19:27:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.25 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1153