Bug 1944855

Summary: Update to nodejs >=14.15.4 for ARM
Product: OpenShift Container Platform Reporter: Samuel Padgett <spadgett>
Component: Management ConsoleAssignee: Samuel Padgett <spadgett>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: high Docs Contact:
Priority: high    
Version: 4.8CC: aos-bugs, jokerman, yapei
Target Milestone: ---   
Target Release: 4.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1944853 Environment:
Last Closed: 2021-04-12 23:22:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1944853    
Bug Blocks:    

Description Samuel Padgett 2021-03-30 19:49:27 UTC
+++ This bug was initially created as a clone of Bug #1944853 +++

See https://issues.redhat.com/browse/CONSOLE-2782

Due to a bug in nodejs:14, ose-console cannot currently be built on ARM with ose-baseubi8.nodejs.14. In order to fix this, a coordinated update of both ose-base to ubi8/nodejs:1-21 and ose-console from 14.15.0 to 14.15.4 would be required. Due to how ose-base is built and used, this would also require a backport to console 4.7 to avoid breaking future z-stream builds (even though ARM will not be enabled thereon).

Comment 5 errata-xmlrpc 2021-04-12 23:22:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1075