Bug 1946474

Summary: F35FailsToInstall: python3-b2sdk
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-b2sdkAssignee: Jonny Heggheim <hegjon>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 35CC: hegjon, majors
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-b2sdk-1.13.0-1.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-12-11 01:32:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1927313    

Description Miro Hrončok 2021-04-06 08:27:46 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (python-b2sdk) Fails To Install in Fedora 35:

can't install python3-b2sdk:
  - nothing provides (python3.9dist(arrow) < 1 with python3.9dist(arrow) >= 0.8) needed by python3-b2sdk-1.4.0-1.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-04-14 12:54:24 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Jonny Heggheim 2021-04-14 16:55:28 UTC
Fedora 35 ships python-arrow-1.0.3, I will wait some time and see if they release a new version that supports version 1+ in some months

Comment 3 Ben Cotton 2021-08-10 12:57:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 4 Majors 2021-11-03 19:32:36 UTC
There's an open dependabot PR for b2sdk to update the arrow version, which I commented on, but it seems like they cannot yet update it due to a need to support older pythons.

https://github.com/Backblaze/b2-sdk-python/pull/204

Comment 5 Fedora Update System 2021-12-02 18:25:22 UTC
FEDORA-2021-cc218f02de has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-cc218f02de

Comment 6 Fedora Update System 2021-12-03 01:49:48 UTC
FEDORA-2021-cc218f02de has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-cc218f02de`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-cc218f02de

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Miro Hrončok 2021-12-11 01:13:36 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 8 Fedora Update System 2021-12-11 01:32:21 UTC
FEDORA-2021-cc218f02de has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.