Bug 1947311

Summary: When adding a new node to localvolumediscovery UI does not show pre-existing node name's
Product: OpenShift Container Platform Reporter: Pratik Surve <prsurve>
Component: Console Storage PluginAssignee: Pranshu Srivastava <prasriva>
Status: CLOSED ERRATA QA Contact: Pratik Surve <prsurve>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.7CC: afrahman, aos-bugs, nberry, nthomas
Target Milestone: ---Flags: nberry: needinfo? (prsurve)
Target Release: 4.8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Feature: Run discovery directly on the node when user clicks that node's respective "Discover Disks" button. Reason: Reduce unnecessary navigation for running LVD. Result: Cleaner and accessible UI for running LVD.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-07-27 22:57:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pratik Surve 2021-04-08 08:03:04 UTC
Description of problem:
When adding a new node to localvolumediscovery UI does not show pre-existing node name's 

Version-Release number of selected component (if applicable):
4.7.0-0.nightly-2021-04-05-201242

How reproducible:


Steps to Reproduce:
1. Deploy OCP with 6W
2. Deploy LSO operator
3. Create LVD by selecting 3 nodes only
4. Try adding a new node to LVD from UI (Compute -> Node -> Disk)

Actual results:
UI does not show pre-existing node name's when adding a new node to LVD

Expected results:
UI should show pre-existing node name's

Additional info:

Comment 7 errata-xmlrpc 2021-07-27 22:57:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.8.2 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:2438